Kawasaki Vulcan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello all long time reader first time poster.
I have an 08 Vulcan 900 classic lt.

When going down highway particularly on hotter days or longer rides my bike will all of sudden loose power but not actually die until coming to a stop then bike will die and when I start back up it has a lopeing idle for a couple seconds then dies. I have to let sit for at least 10 minutes, then start it just to limp back home. Trouble started after charging system failure. I replaced stator,regulator and battery, charging system is good now but stalling still exsists. I also recently replaced the fuel pump, maybe 200 miles ago. Bike does good on morning commute to work about 70F But on the way home I have to "limp" home outside temp. about 90F-100F. Also it felt like clutch is starting to slip If you go WOT in any gear it takes a couple seconds for power to kick in. Not sure if related or not but it happened around same time as well. I want to include all the info I can. I also included a link to a YouTube Video I made this afternoon of bike idling about 85F. About the 30 second mark you can lose ofpower and a muffled engine sound, this is the same sound it makes at highway speeds when troubles begins..

Thanks all in advanced for any help... I searched through other forums but didnt find anything dead on

https://www.youtube.com/watch?v=KHQeB5c95XI
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Also want to add. Backfire from exhaust has been doing that since I bought bike in 2013. Now it will start popping from throttle body intermittently. After sitting for about an hour or will die and not start up again, but I can spray a shot of brake cleaner in throttle body it will start and run about 5 minutes. Repeated this 3 times before it would not start at all
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
I think previous owner changed exhaust. Not sure what kind. But other than that bike is completely stock.
 

·
Registered
Joined
·
11,756 Posts
Can you put air cleaner back on and redo video. All I can hear is a bunch of intake racket.

When it is idling poorly, no revving.
 
1 - 6 of 6 Posts
Top