Fan runs all the time - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-07-2019, 12:27 PM Thread Starter
Junior Member
 
Join Date: Apr 2018
Location: Florida
Year/Make/Model: 1998 Vulcan 800A
Displacement/CC's: 804cc
Color: Blue
Gender: Male
Posts: 4
Garage
Fan runs all the time

I bought a 98 Vulcan 800A. The fan only came on when the motor warmed up... then after shut off it ran for a few minutes then shut off. Last week it didn't come on any. So I checked the fuse and it was blown so I replaced it and it still didn't work. So I bought a new Temp Sensor and fan switch. Now it comes on as soon as I turn the key on and runs the whole time I ride it, then when I shut it off it shuts off as soon as I turn the key off??? Maybe they gave me a wrong switch or maybe a short in wiring???? Any idea?
Curtislowe69 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radiator Fan Runs When Engine Is Shut Off old Vulcan 500 11 01-08-2019 08:04 AM
long time fan first time reg-member vikkiavalon New Member Introductions 9 02-24-2014 12:21 AM
Fan runs frequent. RickW Vulcan 800 11 05-27-2012 05:42 PM
1500 C sat for a long time now only runs with the choke at 100% handle barr Vulcan 1500 4 04-10-2010 06:05 PM
long time rider, first time vulcan owner RedBaron New Member Introductions 10 05-12-2009 08:11 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome