Head light issue - Kawasaki Vulcan Forum : Vulcan Forums
 1Likes
  • 1 Post By texasnurse
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-16-2018, 07:59 PM Thread Starter
Senior Member
 
Join Date: May 2013
Posts: 104
Head light issue

Need to replace the molex plug. That goes directly into the head light.The high beam does not always work. I can make it work but the plug is worn out. Amy suggestions? 2001 800 Classic Thanks.
budda109 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-16-2018, 08:28 PM
Top Contributor
 
texasnurse's Avatar
 
Join Date: Aug 2017
Location: Aggieland
Year/Make/Model: (SOLD) Kawasaki Vulcan S [Harley-Davidson FLXTRS Road Glide Special]
Displacement/CC's: 107 (1746cc)
Color: Bonneville Salt Pearl
Posts: 1,192
https://shop.advanceautoparts.com/p/...E&gclsrc=aw.ds


Saddle up and feel the wind in your Helmet! ATGATT
budda109 likes this.
texasnurse is offline  
post #3 of 3 (permalink) Old 04-16-2018, 08:52 PM Thread Starter
Senior Member
 
Join Date: May 2013
Posts: 104
Thank you so much!
budda109 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
tail light, brake light, running light not working Rider_otStorm General Vulcan Talk 6 02-02-2018 08:35 PM
Half moon on cylinder head gasket issue. Baronthefirst Vulcan 500 8 04-16-2016 10:54 AM
Head light issue DW0378 Vulcan 900 14 07-30-2012 01:44 AM
head torque ft/lbs connecting the pipes to head. hondakiller Engine Work 3 10-09-2009 09:54 PM
Want to upgrade my head light bulb flw General Vulcan Talk 1 05-26-2009 11:14 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome