800 carb problem? - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-12-2016, 04:17 PM Thread Starter
Junior Member
 
Join Date: Aug 2015
Location: Scotland
Posts: 8
Unhappy 800 carb problem?

Hello guys from occasionally sunny Scotland .I have been rebuilding an 06 800 for a while now .Fitted a replacement motor with my original carburetor .I had cleaned the carb before fitting .Had the fuel leaking from the firstly jet holes .Thought float /needle valve ,dirt problem .I stripped carb again thoroughly cleaned it changed needle valve even though it looked ok . checked float height .Fitted again bike will start and run on choke ok when I put the choke in it will run but eventually fuel starts leaking If I rev the engine it turns into a flood of fuel .I obviously suspected a float problem .Carb down again cleaned again changed float .Fitted checked float height .Same again I have rebuilt the petcock even though it seemed ok .I am kinda at the end of my rope with this .Any ideas on where I am going wrong ?
daytona12 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Carb Cleaning: What to Dip and Is Carb Repair Kit necessary? rileyyh Vulcan 500 9 05-13-2016 07:41 PM
Carb problem on my '01 1500 Rustyhammer Vulcan 1500 1 09-01-2010 02:05 PM
1500 carb problem........need help. richw40 Engine Work 6 05-16-2010 10:27 AM
carb problem? eviltwinjames Vulcan 800 11 04-30-2010 12:32 PM
Trash problem in carb SgtWilliam Vulcan 1500 2 04-23-2010 02:23 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome