Indicator lights - Kawasaki Vulcan Forum : Vulcan Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 03-16-2016, 08:17 PM Thread Starter
Junior Member
 
Join Date: Feb 2016
Gender: Male
Posts: 23
Indicator lights

I have looked around and can't find anything on it.

On the Speedo I have 3 lights on my 01 classic, 2 red and 1 green in between the red ones. I know that the green one is my neutral, and my right red is my turn signal, but I cannot figure out what my left red one means. At the same time I am getting my left red and green light will come on after riding for a bit. I just did an oil change and made sure my coolant was full but still got the lights after a quick trip to the gas station.

Sent from my VS986 using Tapatalk
Shon.oconnor is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 03-16-2016, 09:59 PM
Lifetime Premium

Bike Of The Fall Winner 2017

 
GFISH's Avatar
 
Join Date: Mar 2013
Location: San Antonio, Texas
Year/Make/Model: 2006 Vulcan 900 Classic
Displacement/CC's: 903
Color: Silver
Gender: Male
Posts: 2,838
Garage
on my 900 classic. left is neutral, center turn signals and right high beams.

"As long as I have the voices in my head, I'll never ride alone."

2006 Vulcan 900 classic
Mustang Day Tripper seat
Cobra Light Bar
Cobra Air Scoop
Cobra short sissy bar
Cobra Lowers
Baron's front and rear pulley
Baron's Big and Nasty pipes
Leatherlyke hard bags
Blue Superbrites LED accent lights
Chrome Woo Loo Air Horn
Avon Grips
GFISH is offline  
post #3 of 14 (permalink) Old 03-17-2016, 07:16 PM
Senior Member
 
GaHack1's Avatar
 
Join Date: Jun 2012
Location: Thomson Ga
Posts: 158
Maybe this will help.
Attached Thumbnails
Click image for larger version

Name:	cluster.JPG
Views:	62
Size:	52.9 KB
ID:	155210  

1996 VN800A
GaHack1 is offline  
 
post #4 of 14 (permalink) Old 03-17-2016, 07:38 PM Thread Starter
Junior Member
 
Join Date: Feb 2016
Gender: Male
Posts: 23
So mine may have been rewired due to my center light being on when I go to neutral, and turn right light flashes with using turn signals. But center light and left light both come on when I turn the key but when I start the bike the lights go off until I shit the engine off again.

Sent from my VS986 using Tapatalk
Shon.oconnor is offline  
post #5 of 14 (permalink) Old 03-17-2016, 08:18 PM
Senior Member
 
GaHack1's Avatar
 
Join Date: Jun 2012
Location: Thomson Ga
Posts: 158
Wonder what the neutral light it wired to?

1996 VN800A
GaHack1 is offline  
post #6 of 14 (permalink) Old 03-17-2016, 08:25 PM Thread Starter
Junior Member
 
Join Date: Feb 2016
Gender: Male
Posts: 23
That is a good question, my neutral light on the Speedo comes on, and the green light which is normally turn signals comes on as well.

Sent from my VS986 using Tapatalk
Shon.oconnor is offline  
post #7 of 14 (permalink) Old 03-17-2016, 08:46 PM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,717
Key on, which lights come on, not inside speedometer?

Do not ride until this is sorted.
sfair is offline  
post #8 of 14 (permalink) Old 03-17-2016, 08:47 PM Thread Starter
Junior Member
 
Join Date: Feb 2016
Gender: Male
Posts: 23
The left red and green light in the middle

Sent from my VS986 using Tapatalk
Shon.oconnor is offline  
post #9 of 14 (permalink) Old 03-17-2016, 08:48 PM Thread Starter
Junior Member
 
Join Date: Feb 2016
Gender: Male
Posts: 23
On the chart above it w9uld be lights g and h. But mine is wired differently

Sent from my VS986 using Tapatalk
Shon.oconnor is offline  
post #10 of 14 (permalink) Old 03-17-2016, 11:24 PM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,717
It would not have come new like that, so there is a problem somewhere.

Is this something you would like to fix yourself, or?
sfair is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
R&G Racing Fender Eliminator with Kuryakyn LED Torpedo Turn Signal Indicator Lights rdpgreen Vulcan 650 S 5 07-28-2017 08:50 PM
No start, no indicator lights, no sound Logickle Vulcan 500 21 07-22-2015 07:41 AM
Indicator lights wiring Lzrdkng421 Vulcan 800 13 01-28-2014 03:02 PM
both indicator lights on, until i rev up wetsqueegee Vulcan 500 29 10-30-2011 07:06 PM
No indicator lights and no start team5150 Vulcan 1600 1 07-07-2011 06:48 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome