Scewy gear indicator - Kawasaki Vulcan Forum : Vulcan Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 31 (permalink) Old 07-22-2013, 09:16 AM Thread Starter
Top Contributor
 
diehard rider's Avatar
 
Join Date: Jun 2010
Location: Spring Valley IL.
Posts: 851
Scewy gear indicator

I've noticed lately my gear indicator has been play tricks, only when I up shift it flickers back and forth between the gear I'm going up too and the gear I'm leaving than it will stay in the gear I'm in. For there's no misunderstanding, the bike shifts fine it's just the light thats a little screwy. Well than coming home last night I was in 6th gear and the indicator was stuck in 5th and wouldn't jump up no matter what I tried. I might add this only happens in the top 3 gears.

I'm just wondering if anyone was experiencing the same problems and is there a answer why. Thanks!

2012 GREEN/BLACK VAQUERO

Kawi Quick release backrest
Kawi Passanger floorboards
Kawi Luggage rack
Klockwerks 9" windshield
Mustang Seat
Mustang pass backrest pad
Ipod adapter kit/Ipod
Black ISO Grip
Offset ISO highway pegs
PC5 W/ignition
Freedom Performance True Dual Exhaust
Altrimax HP 195/55/16 car tire.
Leather saddlebag chaps
Thunder mfg Tornado air intake
Thunder mfg Throttle Body Gasket
diehard rider is offline  
Sponsored Links
Advertisement
 
post #2 of 31 (permalink) Old 07-22-2013, 09:56 AM
Lifetime Premium
 
Old Bear's Avatar
 
Join Date: Sep 2012
Location: Clarksville, TN
Year/Make/Model: 2017 Kawasaki Vaquero
Displacement/CC's: 1700
Color: Red
Gender: Male
Posts: 2,384
If it won't show the correct gear regardless, then it is a warranty repair. We have had other members with the same issue. On mine, it occasionally doesn't want to show sixth gear, but an extra gentle tap on the shifter gets it showing correctly.

Jerry "Old Bear" Barker
Clarksville, TN
Americas Guardians PS MC
Tennessee 16-A Chapter
"Blaze" 2017 Vaquero
Old Bear is offline  
post #3 of 31 (permalink) Old 07-22-2013, 11:08 AM
Top Contributor
 
captj3's Avatar
 
Join Date: Feb 2011
Location: Boynton Bch FL
Posts: 701
Quote:
Originally Posted by Old Bear View Post
If it won't show the correct gear regardless, then it is a warranty repair. We have had other members with the same issue. On mine, it occasionally doesn't want to show sixth gear, but an extra gentle tap on the shifter gets it showing correctly.
This happens with mine as well. It happens all to often. My old nomad did the same thing, a slight tap to the shifter made the indicater show the proper gear. Strange kawi can't get this right.

2012 Vaquero Candy Lime Green/Black
1700 Nomad (Deceased)
Cobra Tri-Oval Exhaust
Racnrays Invention (Throttle Mod)
Ivan's Flash
Thunder Tornado Air Kit
captj3 is offline  
 
post #4 of 31 (permalink) Old 07-22-2013, 12:07 PM Thread Starter
Top Contributor
 
diehard rider's Avatar
 
Join Date: Jun 2010
Location: Spring Valley IL.
Posts: 851
Yeah I was tapping on the shifter even down shifted to 5th and back to 6th and that usually works for me but last night it was not want to show 6th. Maybe she was pissed at me for having her out in a light rain. lol! I'll take her out today and see if she's still doing it! Plus I always use heel to shift, if it's still doing it I'll try using my toes to up shift and see if that works better. If it's still doing I'll probably take a ride to the dealer and see what they have to say about it, but it will get fixed! I rode a 900 for 4yrs without a indicator and really love having it on the Vaquero when it's working right. lol!

2012 GREEN/BLACK VAQUERO

Kawi Quick release backrest
Kawi Passanger floorboards
Kawi Luggage rack
Klockwerks 9" windshield
Mustang Seat
Mustang pass backrest pad
Ipod adapter kit/Ipod
Black ISO Grip
Offset ISO highway pegs
PC5 W/ignition
Freedom Performance True Dual Exhaust
Altrimax HP 195/55/16 car tire.
Leather saddlebag chaps
Thunder mfg Tornado air intake
Thunder mfg Throttle Body Gasket
diehard rider is offline  
post #5 of 31 (permalink) Old 07-22-2013, 12:09 PM Thread Starter
Top Contributor
 
diehard rider's Avatar
 
Join Date: Jun 2010
Location: Spring Valley IL.
Posts: 851
IMO...The more technology they put into these bikes is the more to go wrong!

2012 GREEN/BLACK VAQUERO

Kawi Quick release backrest
Kawi Passanger floorboards
Kawi Luggage rack
Klockwerks 9" windshield
Mustang Seat
Mustang pass backrest pad
Ipod adapter kit/Ipod
Black ISO Grip
Offset ISO highway pegs
PC5 W/ignition
Freedom Performance True Dual Exhaust
Altrimax HP 195/55/16 car tire.
Leather saddlebag chaps
Thunder mfg Tornado air intake
Thunder mfg Throttle Body Gasket
diehard rider is offline  
post #6 of 31 (permalink) Old 07-22-2013, 12:30 PM
Top Contributor
 
whoaru99's Avatar
 
Join Date: Mar 2010
Posts: 2,923
Not sure how it is on the Vaquero, but when I put Euro gears in my VN2K I got to see how the gear position sensor is laid out in that one. Inside the inner transmission cover there is a sensor with several contact spots on it...one for each gear and neutral. Then, on the shift mechanism there is a spring loaded contact point that grounds the respective sensor contact when you're in that particular gear.

The VN2K only shows Neutral, not each gear, but I believe this sensor may also be used to determine timing advance and perhaps fueling curve.

Again, not sure if the Vaquero is same or different but one would think they'd use similar technology.

Last edited by whoaru99; 07-22-2013 at 12:33 PM.
whoaru99 is offline  
post #7 of 31 (permalink) Old 07-22-2013, 01:29 PM Thread Starter
Top Contributor
 
diehard rider's Avatar
 
Join Date: Jun 2010
Location: Spring Valley IL.
Posts: 851
Quote:
Originally Posted by whoaru99 View Post
Not sure how it is on the Vaquero, but when I put Euro gears in my VN2K I got to see how the gear position sensor is laid out in that one. Inside the inner transmission cover there is a sensor with several contact spots on it...one for each gear and neutral. Then, on the shift mechanism there is a spring loaded contact point that grounds the respective sensor contact when you're in that particular gear.

The VN2K only shows Neutral, not each gear, but I believe this sensor may also be used to determine timing advance and perhaps fueling curve.

Again, not sure if the Vaquero is same or different but one would think they'd use similar technology.
I would think that it would be similar setup and if thats the case I would think that could be the problem and not making the proper contact. Thank god for warranties! Thanks for the info!

2012 GREEN/BLACK VAQUERO

Kawi Quick release backrest
Kawi Passanger floorboards
Kawi Luggage rack
Klockwerks 9" windshield
Mustang Seat
Mustang pass backrest pad
Ipod adapter kit/Ipod
Black ISO Grip
Offset ISO highway pegs
PC5 W/ignition
Freedom Performance True Dual Exhaust
Altrimax HP 195/55/16 car tire.
Leather saddlebag chaps
Thunder mfg Tornado air intake
Thunder mfg Throttle Body Gasket
diehard rider is offline  
post #8 of 31 (permalink) Old 07-22-2013, 02:35 PM
Senior Member
 
Join Date: Jun 2009
Location: Greensburg, Pa
Posts: 117
My 09 Nomad does it too. I usually lift up on the toe shifter a little and it moves up to the right gear. It does it on downshift sometimes too. It doesn't really bother me much but I have gotten so used to having it that when I ride my wife's 900, I get lost in what gear I am in LOLOL.
Now one thing I did notice and maybe it is just a coincidence, but I change my oil every 4000 miles. When I get up over 3000 miles the gear indicator seems to mess up more. I don't want to start any arguments about that but it is what I have noticed. I'm not saying that is the cause either but it sure is funny that it starts to happen more with older oil. By the way I have checked it and the oil level is fine.
Bill
bpro215 is offline  
post #9 of 31 (permalink) Old 07-22-2013, 05:35 PM
Senior Member
 
Join Date: Sep 2011
Location: Columbus WI
Posts: 299
Mine did it to. Had it replaced under warrenty. Lasted a week and started doing the same thing. My friends victory XC tour does it to. They have to remove your drive belt to get to the switch. They will tighten your belt to specs and it will whine. I had to readjust my belt agian. I would'nt bother.
jp58 is offline  
post #10 of 31 (permalink) Old 07-22-2013, 06:39 PM
Lifetime Premium
 
shepsvoyager's Avatar
 
Join Date: May 2012
Location: Sweetser Indiana 2009 Voyager Titanium ABS
Posts: 419
Garage
Running hard

Quote:
Originally Posted by diehard rider View Post
Yeah I was tapping on the shifter even down shifted to 5th and back to 6th and that usually works for me but last night it was not want to show 6th. Maybe she was pissed at me for having her out in a light rain. lol! I'll take her out today and see if she's still doing it! Plus I always use heel to shift, if it's still doing it I'll try using my toes to up shift and see if that works better. If it's still doing I'll probably take a ride to the dealer and see what they have to say about it, but it will get fixed! I rode a 900 for 4yrs without a indicator and really love having it on the Vaquero when it's working right. lol!
I bet You broke it trying to keep up with that badass screaming eagle! We had a couple great days didn't we. Glad we got to ride. Look forward to our next adventure.
shepsvoyager is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why Gear Indicator is not showing proper downshift gear thejunglerider General Vulcan Talk 2 11-01-2016 05:32 PM
Voyager gear indicator issue kiwimyk Vulcan 1700 20 11-14-2014 01:19 PM
gear indicator larryg General Vulcan Talk 0 08-10-2010 07:03 PM
Digital gear indicator TopSecret Vulcan 900 15 07-13-2010 11:15 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome