Kact pump failure - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-27-2018, 05:26 PM Thread Starter
Junior Member
 
gbcornish's Avatar
 
Join Date: Jul 2018
Posts: 4
Kact pump failure

I have a 2011 voyager with a failed kact pump has anyone had issues with their pump
gbcornish is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-28-2018, 11:09 AM
Top Contributor
 
VN750Guy**'s Avatar
 
Join Date: Mar 2018
Location: Fredrickson Washington
Year/Make/Model: 2006
Displacement/CC's: 750
Color: Red/black
Gender: Male
Posts: 1,075
Garage
Can't say that I've heard of any K-ACT pump failure before. By that I mean that I don't remember seeing any forum thread on such a failure. That would lead me to think its a rarity. If it were more common then there would be more chatter about it.

But then, someone else with a K-ACT equipped vehicle may have different memories and experiences. Regardless, sorry to hear that you're having this issue. I doubt it will ever happen again, though.

Chris Cochran
Retired USAF '74 to '95 AMMO
Engine guard with highway pegs
Luggage rack
GPS on RAM handlebar mount
MCCTs replaced ACCTs
Iridium plugs: DPR7EIX-9
Custom made seat (verrry comfortable)
LED turn signals with rear signals relocated
LED license plate holder
Hard mounted Viking saddlebags
Hard mounted fork tool bag (free from Viking)
LED running lights on custom light bar
National Cycles Low Boy Heavy Duty windshield
Home made lowers
VN750Guy** is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kact pump failure gbcornish New Member Introductions 1 07-27-2018 09:02 AM
Fuel Pump failure VulcanRay Vulcan 1500 29 03-06-2015 08:40 PM
Change the fluid in the abs kact? Dozrtravlin Vulcan 1700 8 08-07-2014 11:48 AM
Magnetic Switch Failure steveissak Vulcan 1500 10 08-18-2010 10:41 AM
bazaar clutch system failure pugetsoundsailer Vulcan 1500 1 05-28-2009 09:27 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome