regulator rectifier - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-08-2017, 07:28 AM Thread Starter
Junior Member
 
minesapint's Avatar
 
Join Date: Apr 2013
Location: Buckinghamshire UK
Posts: 24
Unhappy regulator rectifier

Hi when my bike VN1700 was 1 year and one thousand five hundred miles, the regulator rectifier packed up no charge going to battery, dealer said they changed regulator rectifier, 2 off, under warranty
and all was good till now,
now at 4 years and six thousand miles the same thing has happened no charge going to battery looking like the regulator rectifier have packed in again, getting exactly the same symptoms as before,
any one know what would make this happen or am I just unlucky or did Kawasaki have a bad batch of regulator rectifier.
bike is out warranty so will have to fix my self.
and I know I should ride it more then it would packed up when it was still in warranty
PS
If any one has a step by step guide on how I test the regulator rectifier I wold be very happy
thanks for all help

Last edited by minesapint; 07-08-2017 at 12:52 PM.
minesapint is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-11-2017, 11:04 AM Thread Starter
Junior Member
 
minesapint's Avatar
 
Join Date: Apr 2013
Location: Buckinghamshire UK
Posts: 24
Hi just a update for any one having same problem, bike in shop they tested the Generator all good, did a test on the regulator rectifier and they are bad,
so why would a bike from new go through 4 regulator rectifier in less then five thousand miles ? 2 at 1,500 and 2 more at 5,000 miles.
All connectors are good no burnt out or corroded wires, never had any fuses go, never cut into any of the wires, would the ignition wire under tank have any thing to do with it, my bike is not subject to the recall.
Any suggestions thanks for any help
minesapint is offline  
post #3 of 3 (permalink) Old 07-11-2017, 12:51 PM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,714
4 reg/rect's???? Wow!!

What might be happening is you have an intermittent stator short which can take out reg/rect's.
sfair is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
oil coming put of regulator/rectifier ?????? curtm Vulcan 900 15 05-30-2015 12:10 PM
Oil in Rectifier/Regulator Plug!?! RickD Wrench Heads 0 05-23-2015 07:07 PM
Regulator Rectifier jimmytinknocker Vulcan 2000 15 05-26-2014 02:01 PM
Aftermarket regulator/rectifier redfish Vulcan 500 71 06-08-2012 10:13 AM
relocate regulator/rectifier? namessuck Vulcan 900 4 04-05-2010 10:17 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome