Error code 18 and wiring - Kawasaki Vulcan Forum : Vulcan Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 28 (permalink) Old 09-07-2016, 04:42 PM Thread Starter
Senior Member
 
Biker Dash's Avatar
 
Join Date: Jun 2016
Location: Waterville, Maine (Equestria)
Year/Make/Model: 2011 Kawasaki Vulcan Nomad
Displacement/CC's: 1700
Color: Metallic blue/silver
Gender: Male
Posts: 388
Garage
Send a message via Skype™ to Biker Dash
Error code 18 and wiring

I was taking a look at the Error Code sheet, and I noticed this:
Quote:
18 ETV Accelerator position sensor malfunction, wiring open or short.
Now, since I do not like having the issue repeatedly coming back, and the thought of buying a new throttle body assembly makes me feel ill, if it is a bad connection somewhere, maybe I might be able to fix the issue for good, and not have to end up eating Ramen noodles due to being perpetually broke.

My question is, does anyone know where the bad connection might be exactly, and how to best go about checking for a bad connection?

Any help would be greatly appreciated, saving me money that I can use towards getting Celestia IVANIZED, as well as buying the Vaquero pieces I want for her.

2011 1700 Nomad -- "Princess Celestia"
2003 1500 Dodge Ram Quad Cab 5.9 "Nightmare Moon"
Biker Dash is offline  
Sponsored Links
Advertisement
 
post #2 of 28 (permalink) Old 09-08-2016, 01:49 AM
Top Contributor
 
TS Tinker's Avatar
 
Join Date: Jan 2013
Location: Birmingham Al
Posts: 1,229
Garage
Quote:
Originally Posted by Biker Dash View Post
I was taking a look at the Error Code sheet, and I noticed this:


Now, since I do not like having the issue repeatedly coming back, and the thought of buying a new throttle body assembly makes me feel ill, if it is a bad connection somewhere, maybe I might be able to fix the issue for good, and not have to end up eating Ramen noodles due to being perpetually broke.

My question is, does anyone know where the bad connection might be exactly, and how to best go about checking for a bad connection?

Any help would be greatly appreciated, saving me money that I can use towards getting Celestia IVANIZED, as well as buying the Vaquero pieces I want for her.
This Tuesday AM I got the red light FI after leaving the house then two blocks later error 18. So I turned around and drove something else to work. Today I charged the battery for about an hour and there were no codes. Drove it for about 15 minutes. The bike had been sitting for almost a month without me riding it. Low voltage can cause all kinds of phantom problems on these 1700's. When the bike is not throwing a code on start up does the red light stay on for a second or two after start up?

10 Voyager
01 1500 Drifter
VRA Central Alabama Chapter 1-61

Last edited by TS Tinker; 09-08-2016 at 01:53 AM.
TS Tinker is offline  
post #3 of 28 (permalink) Old 09-08-2016, 06:58 PM Thread Starter
Senior Member
 
Biker Dash's Avatar
 
Join Date: Jun 2016
Location: Waterville, Maine (Equestria)
Year/Make/Model: 2011 Kawasaki Vulcan Nomad
Displacement/CC's: 1700
Color: Metallic blue/silver
Gender: Male
Posts: 388
Garage
Send a message via Skype™ to Biker Dash
Quote:
Originally Posted by TS Tinker View Post
This Tuesday AM I got the red light FI after leaving the house then two blocks later error 18. So I turned around and drove something else to work. Today I charged the battery for about an hour and there were no codes. Drove it for about 15 minutes. The bike had been sitting for almost a month without me riding it. Low voltage can cause all kinds of phantom problems on these 1700's. When the bike is not throwing a code on start up does the red light stay on for a second or two after start up?
No, it doesn't, and the battery is in excellent condition with a full charge. The battery connections are tight as well.

2011 1700 Nomad -- "Princess Celestia"
2003 1500 Dodge Ram Quad Cab 5.9 "Nightmare Moon"
Biker Dash is offline  
 
post #4 of 28 (permalink) Old 09-09-2016, 05:26 PM
Top Contributor
 
TS Tinker's Avatar
 
Join Date: Jan 2013
Location: Birmingham Al
Posts: 1,229
Garage
Quote:
Originally Posted by Biker Dash View Post
No, it doesn't, and the battery is in excellent condition with a full charge. The battery connections are tight as well.
Have you tried removing the battery terminals and letting the ECM reset?

10 Voyager
01 1500 Drifter
VRA Central Alabama Chapter 1-61

Last edited by TS Tinker; 09-09-2016 at 05:36 PM.
TS Tinker is offline  
post #5 of 28 (permalink) Old 09-09-2016, 06:37 PM Thread Starter
Senior Member
 
Biker Dash's Avatar
 
Join Date: Jun 2016
Location: Waterville, Maine (Equestria)
Year/Make/Model: 2011 Kawasaki Vulcan Nomad
Displacement/CC's: 1700
Color: Metallic blue/silver
Gender: Male
Posts: 388
Garage
Send a message via Skype™ to Biker Dash
I do not know how that will stop further error codes from happening...

2011 1700 Nomad -- "Princess Celestia"
2003 1500 Dodge Ram Quad Cab 5.9 "Nightmare Moon"
Biker Dash is offline  
post #6 of 28 (permalink) Old 09-09-2016, 07:55 PM
Top Contributor
 
TS Tinker's Avatar
 
Join Date: Jan 2013
Location: Birmingham Al
Posts: 1,229
Garage
It won't, but it will verify it is a hard code.

10 Voyager
01 1500 Drifter
VRA Central Alabama Chapter 1-61
TS Tinker is offline  
post #7 of 28 (permalink) Old 09-09-2016, 09:22 PM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,717
When does the code show up...key on or after riding?
sfair is offline  
post #8 of 28 (permalink) Old 09-09-2016, 10:49 PM Thread Starter
Senior Member
 
Biker Dash's Avatar
 
Join Date: Jun 2016
Location: Waterville, Maine (Equestria)
Year/Make/Model: 2011 Kawasaki Vulcan Nomad
Displacement/CC's: 1700
Color: Metallic blue/silver
Gender: Male
Posts: 388
Garage
Send a message via Skype™ to Biker Dash
Quote:
Originally Posted by sfair View Post
When does the code show up...key on or after riding?
After riding. It could happen within the first mile, or it could happen near the end of a hundred mile long ride, or somewhere in between. I park the bike and shut it down (ignition off) and start it 10-15 seconds later, and it is clear, and the bike seems fine.

2011 1700 Nomad -- "Princess Celestia"
2003 1500 Dodge Ram Quad Cab 5.9 "Nightmare Moon"
Biker Dash is offline  
post #9 of 28 (permalink) Old 09-09-2016, 11:13 PM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,717
Does it seem to happen every ride, or?
Is performance affected?
Does warning indicator blink or on solid?
sfair is offline  
post #10 of 28 (permalink) Old 09-09-2016, 11:27 PM Thread Starter
Senior Member
 
Biker Dash's Avatar
 
Join Date: Jun 2016
Location: Waterville, Maine (Equestria)
Year/Make/Model: 2011 Kawasaki Vulcan Nomad
Displacement/CC's: 1700
Color: Metallic blue/silver
Gender: Male
Posts: 388
Garage
Send a message via Skype™ to Biker Dash
Quote:
Originally Posted by sfair View Post
Does it seem to happen every ride, or?
Is performance affected?
Does warning indicator blink or on solid?
Not every ride. Kinda random.
Performance IS effected when it happens. Power is severely reduced.
And I cannot remember off the top of my head if it blinks or is solid.

2011 1700 Nomad -- "Princess Celestia"
2003 1500 Dodge Ram Quad Cab 5.9 "Nightmare Moon"
Biker Dash is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Code 18, PCV...Extended Warranty not covered? akaimana Vulcan 1700 20 06-17-2016 10:27 PM
Red flashing light and Error 18 robd Vulcan 1700 2 05-05-2015 01:41 PM
error code 18 on 1700 w longggevity Wrench Heads 7 09-09-2014 07:09 PM
error code 18 larryg Vulcan 1700 7 07-26-2014 10:35 PM
Error 18 and flashing red light. nomad11 Vulcan 1700 4 10-21-2013 04:53 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome