Throttle lag? - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-09-2015, 07:47 PM Thread Starter
Lifetime Premium
 
Glenn54's Avatar
 
Join Date: Feb 2015
Location: Hemphill, Texas
Year/Make/Model: 2013 Voyager
Displacement/CC's: 1700
Color: Blue/Black
Gender: Male
Posts: 499
Throttle lag?

Recently purchase a new 2013 Voyager. I only have 70 miles on it but haven't noticed a throttle lag. When does this seem to occur? Does everyone with this bike have it?
Glenn54 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-10-2015, 05:10 PM
Top Contributor
 
twowheeladdict's Avatar
 
Join Date: May 2010
Location: Middle Tennessee
Posts: 2,656
Garage
No, not everyone has it.

Make sure the throttle cables are adjusted correctly. If they are and it still occurs, you might want to try Ray's Throttle Mod.

Mine doesn't have the lag or the intake leaks or the whiny belt or the whiny transmission. About 50,000 miles on the bike and will probably ride it until it becomes unreliable.

2010 Vulcan Voyager 1700 ABS, 2007 Vulcan Mean Streak 1600
2012 Concours 1400, 2011 Versys 650, 2012 KLX250S

see my garage for list of accessories
twowheeladdict is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shaft drive lag Combat_Infantryman Vulcan 1600 11 08-06-2016 09:58 AM
Throttle lag? Glenn54 Vulcan 1700 5 02-10-2015 07:12 PM
Kuryakyn Throttle Boss or Contoured Throttle Boss dolitsky Vulcan 1700 18 03-08-2012 04:54 PM
EN500C (2005) Throttle Response lag? FL500c Vulcan 500 12 10-27-2010 11:24 PM
New Lag Time on this site Rageous Community Help 8 08-24-2010 01:32 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome