Battery Light - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-05-2015, 04:49 PM Thread Starter
Junior Member
 
Join Date: Jan 2015
Posts: 4
Battery Light

Sorry to keep asking questions but I am relatively new to the V. V. and just trying to enjoy the bike as much as possible. Have the 2010 on a battery tender when garaged and the tender's green light is constant indicating a good battery. Have taken the battery to the local Kawi shop for testing. They say it is good. Never hesitates to start nor is it sluggish when starting. BUT, the battery light comes on at the start and stays on for 10 to 15 seconds then goes off. After all that, the question. Is that normal? Just worries me to see a red light on the info center. Any input or thoughts are welcomed!!
lwhnp is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-05-2015, 07:29 PM
Peg
Top Contributor
 
Peg's Avatar
 
Join Date: Dec 2013
Location: West Coast, North Island, New Zealand
Posts: 636
Garage
It's a multi function warning light - for FI, oil pressure, and battery. Pay careful attention to which symbol is lit in the screen above the red light. It could simply be your oil pressure coming up to the required level?

Paul (Peg) Elliott
New Plymouth, NZ. '10 Voyager 1700
'02 Nomad 1500(sold) '97 VN800B (sold)
2 Honda's, 2 Suzuki's, 1 Yamaha (all dead)
Peg is offline  
post #3 of 6 (permalink) Old 02-06-2015, 07:47 AM Thread Starter
Junior Member
 
Join Date: Jan 2015
Posts: 4
Thanks, Peg. Good point. I am aware of the multifunction. It is the battery. Just can't figure this one out. Maybe it's nothing to worry about. Just don't want to be a long way from home and find out it is something!
lwhnp is offline  
 
post #4 of 6 (permalink) Old 02-06-2015, 09:09 AM
Top Contributor
 
reddyford's Avatar
 
Join Date: Apr 2009
Location: 50 miles NE of Buffalo
Posts: 2,001
Garage
Do you have a lot of accessory (load) adds? If you do try turning every non essential load off; such as extra driving lights etc... etc. The stator(s) may be dedicating most of its energy to power these adds before the battery recovers. Hows the start up idle?

08 Classic FI 1500
06 Sporty 1200
reddyford is offline  
post #5 of 6 (permalink) Old 02-06-2015, 09:10 AM
Junior Member
 
minesapint's Avatar
 
Join Date: Apr 2013
Location: Buckinghamshire UK
Posts: 24
does not say battery, just says warning indicator light
the indicator light goes on and flashes when a problem occurs in-
fuel injection/electronic throttle vale system
oil pressure
coolant temperature
does not say anything about charging system
minesapint is offline  
post #6 of 6 (permalink) Old 02-06-2015, 11:59 AM
Top Contributor
 
reddyford's Avatar
 
Join Date: Apr 2009
Location: 50 miles NE of Buffalo
Posts: 2,001
Garage
Quote:
Originally Posted by minesapint View Post
does not say battery, just says warning indicator light
the indicator light goes on and flashes when a problem occurs in-
fuel injection/electronic throttle vale system
oil pressure
coolant temperature
does not say anything about charging system
Not familiar with the VV, just trying to help. Was going on what was said in post #2 & #3 where the batt icon is said to appear.

08 Classic FI 1500
06 Sporty 1200
reddyford is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
tail light, brake light, running light not working Rider_otStorm General Vulcan Talk 6 02-02-2018 08:35 PM
Battery light on dash JerseyMonte Vulcan 1700 4 04-08-2014 11:44 AM
is my battery too weak ? indicated from Kury battery gauge evodog Vulcan 900 17 09-16-2013 10:55 AM
No brake light, No tail light????? UscgMac Vulcan 2000 7 09-04-2010 10:45 PM
Oil Light and Temp Light On Olympic335 Oil and Lubrication 2 07-17-2010 05:00 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome