squeeking after lowering kit install - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-16-2010, 08:46 PM Thread Starter
Member
 
Join Date: Apr 2010
Posts: 31
squeeking after lowering kit install

I'm getting a loud squeek when I hit a bump after installing 3" lowering kit did I do something wrong? Please help I'm a little worried.
namessuck is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-16-2010, 11:17 PM
Senior Member
 
Shiloh's Avatar
 
Join Date: May 2009
Location: Katy Texas
Posts: 209
3 inches, hummm.... Check that your rear tire isn't rubbing on something when the suspension is compressed by zee bummmp.

09 Vulcan 900 Custom - Traveller
09 FZ 6 - Lakota
Shiloh is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Vulcan 900 - Barons rear lowering link and front lowering springs marvinsanremo Bike Parts, exhausts, etc. For Sale 2 11-24-2015 07:59 PM
Baron front progressive spring lowering kit and baron rear lowering kit 900 custom. Tony F. Bike Parts, exhausts, etc. For Sale 5 11-24-2015 07:56 PM
Vulcan 800 chirping/squeeking Vulcan Viking Engine Work 6 06-15-2014 08:07 PM
Squeeking noise from right hand side of engine liverpool Engine Work 0 09-21-2013 08:56 AM
Modify kickstand after lowering 1700 tkerrigan Vulcan 1700 2 08-04-2011 06:59 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome