New Horn - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 01-28-2010, 01:51 PM Thread Starter
Junior Member
 
Join Date: Jan 2010
Location: AUSTIN TX
Posts: 9
New Horn

I was trying to replace the horn on my wifes 900 and the new horn would not work, so I put the old horn back on and it won't work????
BUDDYW is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 01-28-2010, 02:30 PM
Senior Member
 
MINI NSX's Avatar
 
Join Date: Jun 2009
Location: Southern Ohio
Posts: 295
Hook a test light up to both leads to the horn, turn on the key and press the horn button. If you have no electrical issues the light should come on. Otherwise, look for a blown fuse, bad ground, etc.

'09 Vulcan 900 Custom
'08 Concours 14
'05 CBR1000RR Repsol
MINI NSX is offline  
post #3 of 9 (permalink) Old 01-28-2010, 04:00 PM Thread Starter
Junior Member
 
Join Date: Jan 2010
Location: AUSTIN TX
Posts: 9
Is there an in line fuse or in the fuse box?
BUDDYW is offline  
 
post #4 of 9 (permalink) Old 01-28-2010, 04:20 PM
Senior Member
 
Kinnally's Avatar
 
Join Date: Nov 2009
Location: northern new jersey
Posts: 129
I'm assuming you can attach any 12 volt horn..cadillac, semi,..follow the lead back and check any in-line fuses you can see. They wouldn't hide a fuse for the horn. If you take off the left side cover (where the seat release key goes in) you'll see the horn fuse. There is one screw that is exposed once you remove the seat. Check that out.
Kinnally is offline  
post #5 of 9 (permalink) Old 01-28-2010, 04:50 PM Thread Starter
Junior Member
 
Join Date: Jan 2010
Location: AUSTIN TX
Posts: 9
Thanks, I will as soon a sI get home, makes since
BUDDYW is offline  
post #6 of 9 (permalink) Old 01-29-2010, 12:24 AM
Top Contributor
 
V Twin's Avatar
 
Join Date: Jan 2010
Location: Dallas, TX
Posts: 711
+1 on a blown fuse. If that's not the issue then buy a stable horn from any local autoparts for like $15 greens.


Gitty Up & Go!

2007 VN 900 Custom modifications:
Corbin Young Guns Saddle*OEM Classic Gel Flame Saddle (when 2up)*OEM Light Bar*National Cycles Shield*OEM Ribbed Handlebar Grips*OEM Classic Rear Fender*PC III*V&H SCS Pipes (Modified)*Comet Milled BAK*Engine Guard*Genmar Risers*Clear Alternatives Integrated Tail Light*Kury Magnum Plus Mirrors*Kury Cruise Control*Upgraded Horn*Metzler 90/90/21*Avon Venom 200/70/15*Both SW Pulleys.
V Twin is offline  
post #7 of 9 (permalink) Old 01-29-2010, 09:30 AM Thread Starter
Junior Member
 
Join Date: Jan 2010
Location: AUSTIN TX
Posts: 9
Thanks, it was the fuse, go figure!!!!!
BUDDYW is offline  
post #8 of 9 (permalink) Old 02-06-2010, 09:54 PM
Member
 
Mark Honey's Avatar
 
Join Date: Aug 2009
Location: Carle Place, NY (Long Island)
Posts: 59
If you change the stock horn, you MUST put an inline 15 amp fuse on the new horn. I'm sure the new horn is louder (otherwise, why bother, right?) Louder = more power drain. If you just replace the stock fuse with a higher rated fuse to stop it from blowing, you can burn up your wiring.

[SIGPIC][/SIGPIC]Mark Honey

To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
Mark Honey is offline  
post #9 of 9 (permalink) Old 02-07-2010, 10:19 AM
Senior Member
 
Kinnally's Avatar
 
Join Date: Nov 2009
Location: northern new jersey
Posts: 129
Mark...did you get your pipes de-baffled? Stop banging and start drilling. I'm assuming you drilled around the inner baffle with a 1 3/4 hole saw..it will make more wiggle room.
Kinnally is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Wolo Horn Mounts to Down Tube/Bar Roadie Vulcan 1700 22 12-28-2015 09:22 PM
new horn suggestions.... thegodmother Vulcan 800 12 08-02-2012 10:40 AM
Why do I need a Relay for new horn? wallacem Vulcan 500 5 07-23-2012 09:16 PM
relocated horn with linbar installation now horn doesn't work?? Swatcop Vulcan 900 5 05-04-2011 09:13 AM
new horn gmer140 Vulcan 900 2 06-18-2010 11:05 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome