Unusual brake problem - Kawasaki Vulcan Forum : Vulcan Forums
 1Likes
  • 1 Post By Commando
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-26-2019, 08:48 AM Thread Starter
Junior Member
 
Join Date: May 2019
Location: Arizona
Year/Make/Model: 2008 Kawasaki Vulcan 900 Custom
Color: Black
Gender: Male
Posts: 5
Unusual brake problem

I love my Vulcan 900 and have had virtually no problems since owning. I have however had a pesky rear brake issue. Riding one day I noticed the rear brake pedal would go all the way down; no rear brake. I noticed no leaks in the garage or on the bike. I bled the rear brake and pressure returned. I tightened everything down and thought everything was good. Within days same problem and again no leaks. I figured air had to be getting in somehow so figured I'd rebuild the rear master cylinder. I ordered a kit (darkhorsemotorcycleparts.com $20) and spent 30 minutes rebuilding and bleeding system. After two weeks it would appear the problem is resolved. I post this as an FYI as I didn't see this problem specifically in the forum and should it be encountered it's a cheap and quick fix.
Biebs likes this.
Commando is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-26-2019, 11:58 AM
Lifetime Premium
 
Sabre-t's Avatar
 
Join Date: May 2015
Location: Marietta, GA
Year/Make/Model: 2010 Kawasaki Voyager
Displacement/CC's: 1700
Color: Red/Black
Gender: Male
Posts: 1,009
Garage
yep, the master cylinder would have been my guess. glad you found it and got it fixed.

Installed:
RAM mount for TomTom Rider 400 (with anti theft module)
6000k LED Headlight & Spots; Kisan Headlight Modulator (works with LEDs),
__Brake Light Modulator, LED License Plate Holder
Longer Kickstand
Dobeck EJK 3.0
Lucky Mirror Extenders
Misc. RAM Mounts for Cup Holder, SPOT, Phone, etc.
Chuckster BAK, Trailer Hitch and Cooler Rack
Wiring for Trailer
Ray's Throttle Mod
Things to do:
Drilling Baffle Plates (Maybe)
Paint HF Tag Along Trailer to Match Bike

LET'S RIDE
Sabre-t is offline  
post #3 of 3 (permalink) Old 05-26-2019, 05:55 PM Thread Starter
Junior Member
 
Join Date: May 2019
Location: Arizona
Year/Make/Model: 2008 Kawasaki Vulcan 900 Custom
Color: Black
Gender: Male
Posts: 5
Thanks! Never ran into that problem before on any bike but pleased it was an inexpensive fix!
Commando is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Street Ready / Rear Brake Switch Spring issue? rileyyh Vulcan 500 0 06-17-2015 01:43 PM
One Man brake fluid flush procedure. mdsimon80 Vulcan 900 0 11-22-2014 09:28 AM
Vaquero brake problem Crab Vulcan 1700 3 08-18-2012 07:31 PM
Where is rear brake wire under tank Degreaser Vulcan 1500 0 04-30-2012 03:26 PM
Help - Brake Job @#$ up -> what did I miss? lord500 General Vulcan Talk 9 08-15-2011 03:30 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome