2008 VN900 Custom overheating - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-09-2019, 07:42 AM Thread Starter
Junior Member
 
VN900 BAHRAIN's Avatar
 
Join Date: Feb 2019
Posts: 10
2008 VN900 Custom overheating

Hi guys, I have got an issue with my VN900 overheating and the radiator fan is not working, I have checked the fuse is in good condition, what should I do.
VN900 BAHRAIN is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-10-2019, 09:46 PM
Senior Member
 
jbiggers's Avatar
 
Join Date: Aug 2017
Location: DFW area
Year/Make/Model: 2013 Vulcan 900 Classic LT
Displacement/CC's: 900
Color: Sparkle Black and Titanium
Gender: Male
Posts: 318
Garage
Check the coolant level. There is an overflow bottle on the left side, behind a cover with a circle on it, just behind the kickstand. Unfortunately, the temp sensor used by the ECU to turn on the fan, is located near the top of the cooling system. Once it's uncovered by a low coolant level, the fan will no longer work reliably. The fix is a proper coolant level.

It's possible the overflow bottle has fluid, but removing the radiator cap will still confirm a low fluid level. This is a cooling system vacuum problem, but we can discuss that issue if you discover it.

Last edited by jbiggers; 03-10-2019 at 09:49 PM.
jbiggers is offline  
post #3 of 7 (permalink) Old 03-11-2019, 07:29 AM Thread Starter
Junior Member
 
VN900 BAHRAIN's Avatar
 
Join Date: Feb 2019
Posts: 10
Thank you for your advice I will drain the coolant of the radiator and try to proceed as instructed, God bless you
VN900 BAHRAIN is offline  
 
post #4 of 7 (permalink) Old 04-03-2019, 10:18 AM Thread Starter
Junior Member
 
VN900 BAHRAIN's Avatar
 
Join Date: Feb 2019
Posts: 10
Hi guys after draining the radiator cooling liquid and replaced with a genuine coolant still the radiator fan is not working, knowing that I made a complete drain and excellent coolant level and making sure no air is captured anywhere. The fan fuse is in good condition also, Is there any other way to check before opening the complete fan.
VN900 BAHRAIN is offline  
post #5 of 7 (permalink) Old 04-03-2019, 04:28 PM
Top Contributor
 
Hot Cruiser's Avatar
 
Join Date: Jun 2008
Location: South Coastal Oregon
Posts: 1,006
The problem also could be a defective water temperature sensor or a defective cooling system fan motor. Was the system working properly as it should, and then did it suddenly stop working?

'07 Kawasaki Vulcan 900 Classic LT

Jesus is Lord

Last edited by Hot Cruiser; 04-03-2019 at 04:45 PM.
Hot Cruiser is offline  
post #6 of 7 (permalink) Old 04-03-2019, 10:09 PM
Senior Member
 
jbiggers's Avatar
 
Join Date: Aug 2017
Location: DFW area
Year/Make/Model: 2013 Vulcan 900 Classic LT
Displacement/CC's: 900
Color: Sparkle Black and Titanium
Gender: Male
Posts: 318
Garage
Well, now you have to do some troubleshooting. You could remove the fan and apply power, to make sure it runs correctly. It could be a bad temp sensor, as Hot Cruiser said. I haven't checked, but there is most likely a relay that turns the fan on, so you could test to see if it energizes. The service manual has a surprising number of component tests in it and how to do them. Basically, you have to start eliminating what the problem is not, to narrow down what it could be. Sounds like you've already started that with the fuse.

Last edited by jbiggers; 04-03-2019 at 10:16 PM.
jbiggers is offline  
post #7 of 7 (permalink) Old 04-04-2019, 12:16 AM Thread Starter
Junior Member
 
VN900 BAHRAIN's Avatar
 
Join Date: Feb 2019
Posts: 10
Thank you gentleman's I will start testing manually by opening the fan for direct connection if it's the same then will go towards the heat switch relay, it's getting hot here in Bahrain and having the bike running without the fan on, it will cause more damage to the bike, God bless you all...
VN900 BAHRAIN is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
100% fits the VN900 Cruiserone Vulcan 900 72 03-11-2019 05:20 PM
FS: 2008 VN900 Custom Lime Green thehun Bikes For Sale 3 04-27-2013 09:04 PM
Just bought 2008 VN900 Classic LT asbrand Vulcan 900 18 04-14-2013 09:10 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome