Carb Clean - What Happened to my Diaphrams?! (pictures) - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-29-2009, 07:04 PM Thread Starter
Junior Member
 
Join Date: Jun 2009
Posts: 4
Carb Clean - What Happened to my Diaphrams?! (pictures)

So after extracting 4 out of 6 bolts that hold the carbs to the float chamber I finally got the carbs opened and started cleaning. Here are my questions and I'll tackle each one in detail:

1.) Are my diaphragms supposed to look like this?
2.) If there's something wrong with them what would be the consequence?
3.) What's this little o-ring?

1.) Are my diaphragms supposed to look like this?




I noticed that the cover for this chamber had a screw missing as shown here...



and the OTHER carb had what I believe to be an oring missing (shown in question 3). Could this contribute to the messed-upness of the diaphragms?


2.) If there's something wrong with them what would be the consequence?
I took apart the carbs to clean because I was getting random increase and decrease of power. Could these ribboned - melted - whatever diaphragms be a contributing cause?


3.) What's this little o-ring?
I was cleaning the bare main carb piece with a hard brush and this little o-ring showed up out of nowhere:



I assumed it went HERE (if it DOES go here then the other oring is missing on OTHER carb that had BOTH screws):



Thanks everyone.
SyntaxJO is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-29-2009, 08:06 PM
Senior Member
 
cruiser331's Avatar
 
Join Date: May 2009
Location: Erie County PA
Posts: 441
Send a message via Yahoo to cruiser331
It looks like the diaphragms deteriorated most likely because of contaminants in the fuel... alcohol or something else.

2008 Vulcan 900 Classic LT hued in Luminous Polaris Blue and Atomic Silver ~ named T'Pol ~
Having left space dock for another home planet, a 94 Vulcan 750, named Surak, Wine and Black Cherry
Recently added a sweet 2008 Nomad to my Vulcan galaxy, she is RED and BLACK named T'mere
cruiser331 is offline  
post #3 of 3 (permalink) Old 06-29-2009, 09:05 PM Thread Starter
Junior Member
 
Join Date: Jun 2009
Posts: 4
Could it have been because of a missing screw and/or missing o-ring?
SyntaxJO is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 1500 classic carb model clean the coolant filter cruzin Vulcan 1500 6 12-29-2014 07:21 AM
Carb Clean Maybe? yones12 Vulcan 800 7 05-12-2012 01:15 AM
Need detailed instrution on how to take off and clean my carb llcelebrity General Vulcan Talk 0 12-14-2011 06:01 PM
New rider attempting to clean carb jodo4 New Member Introductions 0 12-27-2009 01:14 PM
Backfire/loss of power. Carb clean or..? minton Vulcan 500 26 10-29-2009 10:55 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome