Rear suspension squeak - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-27-2012, 10:40 PM Thread Starter
Junior Member
 
Join Date: May 2010
Location: Albuquerque, NM
Posts: 20
Rear suspension squeak

My '07 Classic with 47,500 miles has developed an up/down squeak in the rear. I just put a new rear tire on and greased the bottom zerks at the same time. (It was squeaking before the tire change.) All the Zerks took more than two pumps.

I do ride in the rain from time to time. The lowest zerk has been broken off for over 20,000 miles. (I did the "install zerk, fill with grease, replace zerk with cap bolt" service to all three.)

I'm thinking it might be time for a complete swingarm/tie rod/rocker arm service. Has anyone else with this many miles found any specific failure points to pay special attention to?

Thanks,
Ken Long
Albuquerque
kenglong is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squeak or tire rubbing noise in rear wsomers Vulcan 1500 4 07-27-2014 09:19 PM
Scootworks fixing the squeak! Jeep Pirate Vulcan 900 24 05-02-2011 02:37 PM
HELP! The squeak is driving me crazy! maryes7 Vulcan 500 28 07-07-2010 11:28 PM
Belt or something goes squeak squeak squeak Toymaker Vulcan 900 2 10-19-2009 06:23 AM
The squeak is gone! maryes7 Vulcan 500 0 05-20-2009 12:33 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome