FI light on with a friends bike? - Kawasaki Vulcan Forum : Vulcan Forums
 1Likes
  • 1 Post By sfair
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-28-2014, 10:50 PM Thread Starter
Top Contributor
 
diehard rider's Avatar
 
Join Date: Jun 2010
Location: Spring Valley IL.
Posts: 851
FI light on with a friends bike?

Just looking to narrow a problem with a friends 2011 900 Classic LT. The FI light has been on for a while I guess and she's just telling me about it on a poker run. So here what I got...The FI lights on and it seems like it's missing off the back cylinder. It has 6000 miles on the bike and the first thing I'm thinking is the rear plug is bad but will a bad plug set out the FI light or do you think it's a vacuum line off? I use to have a 900 and never had this problem, I just wanted some opinions on what it could be before I tear into it, she does have new plugs so I'm changing them regardless the problem.

Thanks!!

2012 GREEN/BLACK VAQUERO

Kawi Quick release backrest
Kawi Passanger floorboards
Kawi Luggage rack
Klockwerks 9" windshield
Mustang Seat
Mustang pass backrest pad
Ipod adapter kit/Ipod
Black ISO Grip
Offset ISO highway pegs
PC5 W/ignition
Freedom Performance True Dual Exhaust
Altrimax HP 195/55/16 car tire.
Leather saddlebag chaps
Thunder mfg Tornado air intake
Thunder mfg Throttle Body Gasket
diehard rider is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-28-2014, 11:06 PM
Top Contributor
 
rick's Avatar
 
Join Date: Mar 2008
Location: New Castle, Indiana
Gender: Male
Posts: 3,880
Garage
Not sure about the 9s, but the 1700s will let you get a trouble code for the reason the light is on. This will make it much simpler to fix the issue. Once you think you have it fixed, disconnect the battery for a couple minutes to clear the codes, then see if it does it again.

2005 800 classic
2012 Voyager ABS
rick is offline  
post #3 of 9 (permalink) Old 06-29-2014, 12:28 AM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,682
1. Disconnecting battery will not clear neither current nor historical codes.
2. You will have to go into diagnostic mode and retrieve the error code(s).
3. Guessing at a problem like this never gets one anywhere.
4. I do not recommend riding with the FI light on.
5. If you want to try and fix the problem, post back.
sfair is offline  
 
post #4 of 9 (permalink) Old 06-30-2014, 08:43 AM Thread Starter
Top Contributor
 
diehard rider's Avatar
 
Join Date: Jun 2010
Location: Spring Valley IL.
Posts: 851
So how do you get into the diagnostic mode? And the battery has been recently changed within the last week so it has been unpluged. Today im going to take a look at it, change the plug and look for any vacuum that could be off or damaged in any way. She doesn't take care of the bike like she should and it pisses me off!

Sent from Motorcycle.com Free App

2012 GREEN/BLACK VAQUERO

Kawi Quick release backrest
Kawi Passanger floorboards
Kawi Luggage rack
Klockwerks 9" windshield
Mustang Seat
Mustang pass backrest pad
Ipod adapter kit/Ipod
Black ISO Grip
Offset ISO highway pegs
PC5 W/ignition
Freedom Performance True Dual Exhaust
Altrimax HP 195/55/16 car tire.
Leather saddlebag chaps
Thunder mfg Tornado air intake
Thunder mfg Throttle Body Gasket
diehard rider is offline  
post #5 of 9 (permalink) Old 06-30-2014, 12:52 PM Thread Starter
Top Contributor
 
diehard rider's Avatar
 
Join Date: Jun 2010
Location: Spring Valley IL.
Posts: 851
5. If you want to try and fix the problem, post back.[/QUOTE]

Don't wanna sound like a smart ass and I'm sorry but if I didn't wanna fix the problem for her I wouldn't have posted in the first place.

Mean while I did change the plugs and it is running better but the light is still on Like i figured it would be. I looked for any vacuum line that might of came off but didn't fined anything. So how do I get into the codes and is there a way to reset them or will they go off when it's fixed?

Thanks!

2012 GREEN/BLACK VAQUERO

Kawi Quick release backrest
Kawi Passanger floorboards
Kawi Luggage rack
Klockwerks 9" windshield
Mustang Seat
Mustang pass backrest pad
Ipod adapter kit/Ipod
Black ISO Grip
Offset ISO highway pegs
PC5 W/ignition
Freedom Performance True Dual Exhaust
Altrimax HP 195/55/16 car tire.
Leather saddlebag chaps
Thunder mfg Tornado air intake
Thunder mfg Throttle Body Gasket
diehard rider is offline  
post #6 of 9 (permalink) Old 06-30-2014, 05:00 PM
BOTM Winner, August 2013
 
SAND_MAN1's Avatar
 
Join Date: Jun 2012
Location: Ft. Worth, TX
Posts: 202
Garage
There's a connection on the back of the air filter, if it's not in it will light up. It's by the idle adjustment. I forgot to connect it once and it lit up right away.

2011 Vulcan 900 Classic SE
Cobra Engine Guard
14" Ape hangers w/Baron's Stainless Steel Cables
3" Road Burner Exhaust
Cobra Fi2000R
Barons Big Air Kit
Headlight Visor
Smoked turnsignals
SAND_MAN1 is offline  
post #7 of 9 (permalink) Old 06-30-2014, 06:06 PM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,682
To retrieve current error code:

1. Around the tool box, there should be an open ended yellow wire.
2. Insert a jumper wire long enough to reach battery ground.
3. Turn on key.
4. Ground yellow jumper wire to battery negative.
5. FI light will blink.
6. Here is the tricky part. The error codes are two digits, eg. 21, 32, etc.
We will use 32 for an example. The FI light will blink the tens unit first and they will be longer blinks, then the units digit next and they will be shorter blinks. Now using the 32 as an example, it will be 3 longer blinks, rest and then 2 shorter blinks and then rest. If there is only one code stored, it will repeat over and over. If there is more than one code, they will follow the first one until all have been dumped.
For example, if you had a 32 AND a 12, it will start with the lowest numerical code first, so you would see long blink (1), rest, two short blinks (2) rest, three long blinks (3) and two short blinks (2). Then it will repeat.
When all of the codes have been retrieved, key off, remove jumper.

Post back with codes.
RichOldMan likes this.
sfair is offline  
post #8 of 9 (permalink) Old 06-30-2014, 08:21 PM Thread Starter
Top Contributor
 
diehard rider's Avatar
 
Join Date: Jun 2010
Location: Spring Valley IL.
Posts: 851
Ok thanks...I'll try that!

Sent from Motorcycle.com Free App

2012 GREEN/BLACK VAQUERO

Kawi Quick release backrest
Kawi Passanger floorboards
Kawi Luggage rack
Klockwerks 9" windshield
Mustang Seat
Mustang pass backrest pad
Ipod adapter kit/Ipod
Black ISO Grip
Offset ISO highway pegs
PC5 W/ignition
Freedom Performance True Dual Exhaust
Altrimax HP 195/55/16 car tire.
Leather saddlebag chaps
Thunder mfg Tornado air intake
Thunder mfg Throttle Body Gasket
diehard rider is offline  
post #9 of 9 (permalink) Old 07-03-2014, 05:09 PM
Member
 
Join Date: Apr 2012
Location: Modesto, CA
Posts: 48
Garage
Quote:
Originally Posted by SAND_MAN1 View Post
There's a connection on the back of the air filter, if it's not in it will light up. It's by the idle adjustment. I forgot to connect it once and it lit up right away.
I broke this sensor when I first changed out my air filter intake and the FI light came on until I replaced the sensor. I think the sensor cost about $18. Very easy to replace.


Sent from Motorcycle.com Free App
Ezrider is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
91 vulcan, friends bike needs some help dtmmil New Member Introductions 3 06-04-2013 09:14 AM
FI light came on today and bike was losing power. customvulc Vulcan 900 10 05-29-2013 03:14 AM
fi light came on now bike wont run mrutah12 General Vulcan Talk 4 09-26-2011 09:50 PM
Hi Friends lovejenete New Member Introductions 6 12-13-2009 11:22 AM
Looking for New friends to tour with in MN J-Bone76 New Member Introductions 1 08-26-2009 08:26 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome