Thinking about taking the BAK & PC3 off my bike.... - Kawasaki Vulcan Forum : Vulcan Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 54 (permalink) Old 10-11-2010, 08:54 AM
shawnturner
Guest
 
Posts: n/a
Thinking about taking the BAK & PC3 off my bike....

I have the 2009 Kawasaki Vulcan 900. I put the BAK & power commander 3 on my bike last Spring. I also had it dynoed to perfection! The bike was awesome all summer. I could cruise all day long at 80-85 smooth as can be.
I noticed about a month ago that the bike all of a sudden without any changes made to the bike, started popping big time on deceleration, idle no longer consistant and can only take the bike up to around 70. I could go faster but the bike vibrates so bad I back off. The motor does not even sound like it use to.
I took it to the dealer Saturday morning to let them check it out. One of the guys took it out for a ride and came back to say that the bike seems fine to him. He said thats the way the bike should run. I STRONGLY DISAGREE!!!
I dont even like riding it anymore. Either I am taking the BAK & PC3 off or selling my bike. There is no way I would have bought a bike I cant ride on the freeway. I bought a cruiser to cruise. Why is it so rough to ride now? The bike only has 6800 miles on it and I feel like I need a new motor.
I really wish I could have the bike back the way it was before. I miss riding so much but it is such a disappointment to try to ride this bike like I use to.
 
Sponsored Links
Advertisement
 
post #2 of 54 (permalink) Old 10-11-2010, 08:59 AM
Junior Member
 
Join Date: Aug 2009
Location: Olathe, KS
Posts: 8
Check your exhaust bolts. Mine had started backfiring big time, along with a lower idle. I started looking and one of my exhaust bolts had worked loose.
DITW is offline  
post #3 of 54 (permalink) Old 10-11-2010, 09:22 AM
Senior Member
 
Join Date: Apr 2010
Posts: 138
How long have these symptoms persisted? Is it a recent thing say maybe some bad gas?

Just a thought since the problem came up all of a sudden.
otrp is offline  
 
post #4 of 54 (permalink) Old 10-11-2010, 09:31 AM
shawnturner
Guest
 
Posts: n/a
Quote:
Originally Posted by otrp View Post
How long have these symptoms persisted? Is it a recent thing say maybe some bad gas?

Just a thought since the problem came up all of a sudden.
It started about a 4-6 weeks ago. I have went through a few tanks of gas. I am just mad at myself for spending $1000.00 to make the bike the best it can be & now I will have to spend another $200.00+ to have the BAK & power commander 3 off my bike.
 
post #5 of 54 (permalink) Old 10-11-2010, 09:55 AM
shawnturner
Guest
 
Posts: n/a
Also, while I am waiting at a stop light the bike now vibrates and shakes like the Harleys. I sure hope I can fix this recent change with my bike or I know I will take a big loss when I try to sell this bike. I miss riding!
 
post #6 of 54 (permalink) Old 10-11-2010, 11:19 AM
Senior Member
 
seandh07's Avatar
 
Join Date: Jun 2010
Location: Fredericksburg, VA
Posts: 245
valve adjustment maybe?! i know its way soon but depending on how you ride it could affect it. or possibly need an oil change?!

Seandh07
SGT USMC
seandh07 is offline  
post #7 of 54 (permalink) Old 10-11-2010, 05:18 PM
Top Contributor
 
Join Date: Apr 2010
Location: Somewhere near Parkville, MO
Posts: 976
Didn't we just have this conversation last week?
MrClean is offline  
post #8 of 54 (permalink) Old 10-11-2010, 05:50 PM
Member
 
vic ioina's Avatar
 
Join Date: Oct 2010
Location: South Texas
Posts: 96
Check exhaust bolts like previous person said, I had similar problem before, I replaced seals and bolts and bike runs great. I love my 900!
vic ioina is offline  
post #9 of 54 (permalink) Old 10-11-2010, 06:03 PM
Member
 
mibeaulieu's Avatar
 
Join Date: Jun 2010
Location: CT
Posts: 78
does the pc 3 use wire taps for the tps? That could be your problem. Take the wire taps off and solder the connections.

_________________
Recovering 900 Custom owner
2015 HD Street Glide Special
mibeaulieu is online now  
post #10 of 54 (permalink) Old 10-11-2010, 07:33 PM
Member
 
Join Date: Aug 2010
Posts: 36
I have never understood why people take a brand new bike and start modifying the engine to gain what 3-4 hp. I'm not criticizing OP everybody seems to want to do it. I just think the gain is so minimal why do it this might happen.
OZARK VULCAN is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ivan's Reflash - to BAK or not to BAK first? VulcanDan61 Vulcan 1700 17 05-19-2016 03:43 PM
If you're thinking about taking out the baffles in a 900 custom hunter2E Vulcan 900 63 04-30-2015 07:52 PM
BAK trouble 2008 and PC3 question jonb357 Vulcan 2000 2 06-26-2014 02:24 AM
Dyno results are in 89octane, PC3, K&N air intake , Stck pipes smille5291 Vulcan 2000 5 01-02-2012 07:32 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome