Electrical ? on light bar. - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-15-2010, 04:23 PM Thread Starter
Member
 
Join Date: Oct 2009
Location: Stueben county New York
Posts: 34
Electrical ? on light bar.

I have a 2008 Vn 900 classic, when I bought it already had a Show Chrome 2 3/8 in. Contour Driving light kit on it. The person who installed it didn't pay very much attention to having clearance for the switch that was put on the left side cover on the side of the motor and when you put the cove on the switch hits the mounting bracket for the cover. I have replaced the switch once because of it hitting and the vibration the switch shorted out. When I put the new switch on I wraped it the best I could with elec. tape so this wouldn't happen again. Anyway somethings wrong again. Before I replace the switch again I need to know what amp fuse should be in the inline fuse holder for this light (couldn't read the original)? Also I would like to know what the relay is for, for this light. Is this relay really needed? Could the light just be wired with an inline fuse on the power source before the switch to the light? I have many years of ac electircal (industrial) experience, but very little dc 12 volt. But any help anyone could give me would be great. And I would be very grateful!! Thanks
Bucky is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-15-2010, 04:53 PM
Senior Member
 
RHKman's Avatar
 
Join Date: Apr 2010
Location: Jal New Mexico USA
Posts: 445
Should be 10a fuse and the relay is needed to keep lights from drawing to much juice. you can find diagram of wiring on gadget page. hope this helps

Live to ride and keep it safe
Robert


2011 Victory Vision pearl white/ Pearl the White Lady
1999 VN800b4 classic
Mods
1 kury iso flame grips
2 cobra slash pipes
3 cobra floor boards
4 MS fats windscreen
5 kury iso highway peggs
6 kawi light bar
7 kury mirrors
8 kury swingwing pass peggs
9 sissybar with pass back rest and rack
10old leather saddle bags
11 hard chrome volt meter
12 mustang solo seat with back rest
RHKman is offline  
post #3 of 4 (permalink) Old 08-15-2010, 05:47 PM
Senior Member
 
xcbullet's Avatar
 
Join Date: Mar 2010
Location: Med MI. Clio
Posts: 343
The relay is only needed if you want it to come on with the lights,& or more important is to shut off when you shut off the bike.This way you don't draw the power on the same line as the lights just use it to switch relay.You could just have a toggle just have to turn it off all the time.I have mine like Gadgets with no toggle

http://www.gadgetjq.com/wiredrivinglights.htm

06 Vulcan 900 classic-Totaled

Vance & Hines staggered, PC3, K&N in stock opened up box, Darkside

Over & out
xcbullet is offline  
 
post #4 of 4 (permalink) Old 08-15-2010, 06:33 PM Thread Starter
Member
 
Join Date: Oct 2009
Location: Stueben county New York
Posts: 34
Thanks!

Thanks for the info. I haven't dug into trying to find out what is wrong yet. When my recent problem with this light started I had shut the bike off (the driving lights don't come on until the bike is running) At work and started to walk into work and remembered that I had forgotten my keys and walked back to my bike and the driving lights were on. I tried to turn them off with the switch and they stayed on (key not on). I then started the bike up and moved it to where I had better light to look at it. I turned the light off with the switch (they went off) parked the bike, they came back on then went off again. I shut the bike off and tried to turn the driving lights on, they didn't. That afternoon, after work I took the side cover off where the switch is to see if I could see anything, turned the light on and off a few times and the fuse blew. I'll start with checking the switch with my meter and try to find a new relay some place.Thanks!
Bucky is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
tail light, brake light, running light not working Rider_otStorm General Vulcan Talk 6 02-02-2018 08:35 PM
Light bar light bulb Pezgoon Vulcan 1600 4 03-15-2016 04:47 PM
Electrical Problem with Cobra Light Bar and Tail Light Fuse TMCinDC Vulcan 900 2 04-24-2015 01:01 PM
Electrical Connections Run-Brake light kit cnile Vulcan 900 5 12-14-2011 04:35 PM
Electrical Problem + Temp Light fredakraft General Vulcan Talk 1 11-16-2010 06:05 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome