Need help please. - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-23-2019, 03:17 PM Thread Starter
Junior Member
 
96finder's Avatar
 
Join Date: Apr 2019
Posts: 5
Need help please.

I just bought a 2003 Vulcan Classic 1600 with efi. It has a hypercharger air intake and I am looking for install instructions and maybe pics or video so I can check to see if it was done right cuz I noticed the butterflies where closing when giving fuel. Help please.
96finder is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-23-2019, 07:44 PM
Member
 
Tynker's Avatar
 
Join Date: Jan 2019
Location: Rosharon, TEXAS
Year/Make/Model: 2009 Kawasaki Classic LT
Displacement/CC's: 1700
Color: Green & Silver
Gender: Male
Posts: 84
Make sure the vacuum line is connected in the rear of the mounting plate.
Tynker is offline  
post #3 of 3 (permalink) Old 04-23-2019, 07:47 PM Thread Starter
Junior Member
 
96finder's Avatar
 
Join Date: Apr 2019
Posts: 5
What about the cylinder vents. Do you have any pics of properly done one.
96finder is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome