Ecu - Kawasaki Vulcan Forum : Vulcan Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 11-19-2018, 06:27 PM Thread Starter
Lifetime Premium
 
bbbusmc's Avatar
 
Join Date: May 2016
Location: Jacksonville, Florida
Year/Make/Model: 2006 Vulcan Nomad
Displacement/CC's: 1600
Color: Black
Gender: Male
Posts: 12
Garage
Ecu

Anyone ever have their "Brain" shit out on em? I'm thinking mine gave up. 06 1600 Nomad, been running great, went on a decent ride, stopped to get gas, bike had trouble starting. It cranks finally and I get it in the garage. Next afternoon couldn't get it to start, changed fuel pump, plugs, unhooked cobra fi, nothing. Now after all that if I turn the key on it blows the ECU fuse. Anyone?
bbbusmc is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 11-19-2018, 08:17 PM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,690
Why did you change fuel pump?
sfair is offline  
post #3 of 12 (permalink) Old 11-20-2018, 05:46 AM Thread Starter
Lifetime Premium
 
bbbusmc's Avatar
 
Join Date: May 2016
Location: Jacksonville, Florida
Year/Make/Model: 2006 Vulcan Nomad
Displacement/CC's: 1600
Color: Black
Gender: Male
Posts: 12
Garage
Chaged it cause I wasn't seeing, smelling fuel in the carb or coming out the plug holes. Only getting a slight trickle out of the pump when the fuel line was disconnected and I turned the key on.
bbbusmc is offline  
 
post #4 of 12 (permalink) Old 11-20-2018, 07:28 AM
Member
 
DaPreacha's Avatar
 
Join Date: Aug 2017
Location: Rockingham, NC
Year/Make/Model: 2012 Kawasaki Nomad
Displacement/CC's: 1700
Color: Red/silver
Gender: Male
Posts: 89
I had an 06 classic that had a bared wire under the seat that would blow the main fuse every time I hit a bump in the road. I had to strip the bike down and follow wires until I found it. Ended up being on a corner going around the battery box to the ECU. Fixed it and put foam on the corner and never had another problem with it.
DaPreacha is offline  
post #5 of 12 (permalink) Old 11-20-2018, 09:39 AM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,690
Quote:
Originally Posted by bbbusmc View Post
Chaged it cause I wasn't seeing, smelling fuel in the carb or coming out the plug holes.
1. ???? Your bike is fuel injected; what do you mean by carb and plug holes?
2. Did you do a fuel pressure and volume check on fuel pump?
3. Was replacement pump OEM?
sfair is offline  
post #6 of 12 (permalink) Old 11-20-2018, 11:05 AM Thread Starter
Lifetime Premium
 
bbbusmc's Avatar
 
Join Date: May 2016
Location: Jacksonville, Florida
Year/Make/Model: 2006 Vulcan Nomad
Displacement/CC's: 1600
Color: Black
Gender: Male
Posts: 12
Garage
Still has a carb, its why you a choke, and if you take off the air box and open the butterfly you can see gas shoot into it, if you pull the plugs you can look into the hole. No pressure test/ didn't know.
bbbusmc is offline  
post #7 of 12 (permalink) Old 11-20-2018, 11:06 AM Thread Starter
Lifetime Premium
 
bbbusmc's Avatar
 
Join Date: May 2016
Location: Jacksonville, Florida
Year/Make/Model: 2006 Vulcan Nomad
Displacement/CC's: 1600
Color: Black
Gender: Male
Posts: 12
Garage
And yes pump was OEM replacement
bbbusmc is offline  
post #8 of 12 (permalink) Old 11-20-2018, 11:16 AM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,690
OK, something not right here:

1. All 2006 1600 Nomads were FI.
2. How many miles on it?
3. How long have you owned?
4. Was the fuel pump in tank or external
5. You even mention disconnecting Cobre FI.
sfair is offline  
post #9 of 12 (permalink) Old 11-20-2018, 11:32 AM Thread Starter
Lifetime Premium
 
bbbusmc's Avatar
 
Join Date: May 2016
Location: Jacksonville, Florida
Year/Make/Model: 2006 Vulcan Nomad
Displacement/CC's: 1600
Color: Black
Gender: Male
Posts: 12
Garage
Throttle body instead of carb, if that helps. Had it 7 yrs, pump is in tank, 70,000 miles
bbbusmc is offline  
post #10 of 12 (permalink) Old 11-20-2018, 11:33 AM Thread Starter
Lifetime Premium
 
bbbusmc's Avatar
 
Join Date: May 2016
Location: Jacksonville, Florida
Year/Make/Model: 2006 Vulcan Nomad
Displacement/CC's: 1600
Color: Black
Gender: Male
Posts: 12
Garage
Disconnect Cobra go to see if it was the issue, thats when ECU fuse started blowing
bbbusmc is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mileage with the new ECU twowheeladdict Vulcan 1700 86 04-22-2011 09:39 PM
Have you had your ECU replaced?comments rrjsandman Vulcan 1700 107 01-31-2011 01:55 AM
Wrong ECU installed for Recall GONRDN Vulcan 1700 2 11-16-2010 09:50 AM
Vulcan 900 Recall ~ECU Problems~ [2009-2010] durox Vulcan 900 3 10-31-2010 09:23 AM
2009 ECU reflash mitchkeller87 Vulcan 900 4 03-06-2010 01:17 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome