1600 Mean Streak Idle/Shifting RPM Issue - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-22-2017, 08:57 PM Thread Starter
Junior Member
 
Join Date: Apr 2017
Location: Oak Harbor, Wa
Year/Make/Model: 2006 Kawasaki Vulcan 1600 Mean Streak
Displacement/CC's: 1600
Color: Red/Black
Gender: Male
Posts: 3
Unhappy 1600 Mean Streak Idle/Shifting RPM Issue

Hey everyone,

This might seem a little long winded, but here go. New rider here. I just picked up a 2006 Mean Streak 1600 at the beginning of April and joined the forum here to ask about an issue that I'm having. A couple weeks ago, I went to install a Hypercharger to replace my stock air box. However, once I got almost everything together, I realized that not all the parts were included. So I put all the stock parts back where they went. After a headache here or there, she runs almost like she did before I tinkered with it. The problem I was having was when I gave some throttle, up to over 3k, the bike would stay at that RPM. The only way I was able to get it to come down was to put it in gear, and slowly release the clutch until it climbed down. However, once I pulled the clutch back in, it would climb back up, without me applying throttle at all.

During my disassembly, I took the intake manifold off and when I replaced it, I didn't replace the gaskets (i know, rookie move) but I ended up taking to a mechanic. He removed everything I did (air box, air ducting, throttle body, intake manifold) replaced all gaskets, a reinstalled. Now it's having another issue that stumps even the mechanic. I'll do my best to describe it:

When idling, the bike hovers at about 600 RPM (manual says it should be at 900-1000). When I put it in gear with the clutch pulled, it drops to 400-500 RPM, barely enough to keep it running, and then it dies. However, if i keep tapping the throttle, it stays running. When I actually ride it and am cruising at about 2500 RPM and let go of the throttle, the bike continues to run at 2500 RPM and very slowly revs down, until it hits about 2000 RPM, then suddenly drops off. I'm completely stumped and I hope I can get some sort of an idea here.

-Zach
za92ch03 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-29-2017, 09:55 AM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,690
Still sounds like you have a vacuum leak.
Take a spritz bottle filled with soapy water, spray around anything you had apart and look for bubbles to quickly disappear.
sfair is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why are my idle RPM's periodically not coming to full idle when stopped ? mark482 Wrench Heads 0 08-25-2018 06:39 PM
Where to find Mean Streak Special Edition decals? "Vulcan, Mean Streak, 1600" and "Ka kissmydrums Vulcan 1600 1 03-18-2015 02:30 AM
Picked up a 2008 Mean Streak SE Yesterday! NEED SOME MEAN STREAK OWNER OPINIONS MOLON LABE Vulcan 1600 1 08-06-2013 08:51 AM
Can 06 mean streak wheels fit an 03 mean streak. cuba1808 Wheels and Tires 0 01-18-2012 09:13 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome