Clutch questions - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-03-2016, 06:06 AM Thread Starter
Junior Member
 
greenstreak1600's Avatar
 
Join Date: May 2016
Posts: 3
Garage
Clutch questions

So i had a failing clutch spring that was causing slippage, replaced factory spring with a barnett and it was engaging at the bottom of the lever throw as if brand new. It seems like the engagement point has slowly been moving up and it doesn't engage till half release almost at the end of the throw now like it was before. Is this normal? I just had fork seals done which shouldn't have anything to do with this. Bike is a 06 mean streak 1600 29k miles
greenstreak1600 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-05-2016, 10:17 PM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,715
Quote:
Originally Posted by greenstreak1600 View Post
almost at the end of the throw now like it was before. Is this normal?
This is normal.
sfair is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions questions questions Heathen129 Vulcan 2000 3 05-07-2016 11:41 AM
clutch questions.... chicagoster Vulcan 500 7 08-02-2010 02:15 AM
Clutch Questions Pretzel General Vulcan Talk 2 07-06-2009 05:39 PM
06 1500 classic clutch questions. ripster Vulcan 1500 4 03-29-2009 11:15 PM
Clutch cable questions Hollywood98 Vulcan 900 0 03-11-2009 08:40 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome