Fuel Injector Harness/Conmector ?’s - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-30-2019, 07:41 PM Thread Starter
Junior Member
 
Join Date: May 2019
Location: Clinton, LA
Year/Make/Model: 09 Kawasaki Vulcan 2K Classic LT
Displacement/CC's: 2053
Color: Black/Maroon
Gender: Male
Posts: 5
Garage
Fuel Injector Harness/Connector

So long story short. Bought the bike with a Cobra Fi2000 already installed. Getting things taken apart and going through the wiring it looks like they hooked the connectors up backwards. Furthest connector from the tuner was hooked up to the rear injector. Closest was to the front.

I took the tuner connectors off and per Cobra instructions, put the connector furthest away (from the module) on the front (#1) injector and the closest on the rear (#2). Now coming off the OEM harness there is one shorter lead with a small "F" on the loom and one longer lead with no markings. The smaller F marked lead should go to the front injector? I'm asking because both connectors will fit either injector...dumb move on Kawasaki IMO.

Everything is back together and running now. I took it for a short test drive. I will have it back apart Tuesday when the Barons BA intake comes in. Just trying to go through and fix what the last "mechanic" did.



Trying to add a photo? Here's a direct link http://i66.tinypic.com/2qdtogm.jpg

Last edited by dk.easterly; 05-30-2019 at 09:50 PM.
dk.easterly is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-30-2019, 09:13 PM Thread Starter
Junior Member
 
Join Date: May 2019
Location: Clinton, LA
Year/Make/Model: 09 Kawasaki Vulcan 2K Classic LT
Displacement/CC's: 2053
Color: Black/Maroon
Gender: Male
Posts: 5
Garage
Doing a bit of research and I've found what's hopefully a good wiring diagram for the system.

BL/R wire goes to #1 injector and BL/G wire goes to #2 injector. The connectors were reversed. Hopefully no damage was done with it being run for almost 2k miles like that. If so, I have the paperwork from the so-called mechanic that did the work from the previous owner.
dk.easterly is offline  
post #3 of 4 (permalink) Old 05-31-2019, 09:58 PM
Top Contributor
 
whoaru99's Avatar
 
Join Date: Mar 2010
Posts: 2,926
BL/R to #1 and BL/G to #2 is what the factory diagram shows for my 2008.

Not familiar with that tuner but if both the input and output connections were reversed then perhaps it's six of one, half dozen of another.

Or, depending on how the injectors fire it may not matter at all.

If you can't tell any major difference in how it runs with the wires changed back, then I think likelyhood of damage is quite low if any chance at all.

Last edited by whoaru99; 06-01-2019 at 06:18 AM.
whoaru99 is offline  
 
post #4 of 4 (permalink) Old 06-04-2019, 11:07 AM Thread Starter
Junior Member
 
Join Date: May 2019
Location: Clinton, LA
Year/Make/Model: 09 Kawasaki Vulcan 2K Classic LT
Displacement/CC's: 2053
Color: Black/Maroon
Gender: Male
Posts: 5
Garage
Thanks for the reply. Yes, both connectors were completely reversed. Its is running smoother now than it was before.
dk.easterly is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome