Headlight problem. - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-30-2016, 09:32 PM Thread Starter
Senior Member
 
Join Date: Nov 2009
Location: Grafton NSW Australia
Posts: 159
Unhappy Headlight problem.

I am the owner of a 2009 Classic LT and have noticed over the past few weeks the headlight will sometimes turn off usually at very inconvenient times such as night time on a country road, or not come on at all. I went through all of the usual suspects such as fuse, cracked wire, bulb but nothing could I find. I changed the fuse and the bulb just in case only to find no light at all. I removed the wiring out of the headlight shell to give it a good going over and found it was all good. I also pulled apart the dimmer switch and cleaned it and when it was assembled I had lights, but now this morning after putting everything back to together again nothing. I used a test light and I have power to the switch and the headlight connector but the test light also lights up when I touch the probe to the switch body and in fact any metal part of the bike. Is this normal? I am a complete babe in the woods when it comes to electrical stuff and I tell ya it is driving me mad. All the wires are still well insulated with no worn wires that I can see. Anyone got any ideas as I will not ride the bike without a working headlight. Oh and all the other lights work as expected as does the horn. I am thinking it maybe the switch and will pull it apart again and have a look with a magnifying glass. Any assistance would be most appreciated.

Cheers and Beers.

Bob
Popeye is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-30-2016, 09:46 PM
Junior Member
 
Sparquelito's Avatar
 
Join Date: Jul 2016
Location: Northern Alabama
Year/Make/Model: 2015 Vulcan S ABS
Displacement/CC's: 649
Color: Black
Gender: Male
Posts: 22
Send a message via Yahoo to Sparquelito Send a message via Skype™ to Sparquelito
Hmmmm........
Attached Thumbnails
Click image for larger version

Name:	Merrin motorcycle.jpg
Views:	48
Size:	18.0 KB
ID:	170569  

Am I alone in this?
Am I alone?
Sparquelito is offline  
post #3 of 5 (permalink) Old 07-30-2016, 10:11 PM
Top Contributor
 
Join Date: Apr 2009
Posts: 11,714
A 900, I assume, or?
sfair is offline  
 
post #4 of 5 (permalink) Old 07-30-2016, 11:09 PM
BOTM Winner
October 2016

 
V2K_Rod's Avatar
 
Join Date: Aug 2012
Location: Portsmouth, VA
Posts: 537
Did you check your battery connections to be tight. The test light on any part of the frame lighting up isn't right. You may have a loose ground somewhere.

Sent from my SAMSUNG-SGH-I537 using Tapatalk
V2K_Rod is offline  
post #5 of 5 (permalink) Old 08-01-2016, 11:45 PM Thread Starter
Senior Member
 
Join Date: Nov 2009
Location: Grafton NSW Australia
Posts: 159
I finally sorted the problem but I am not sure how. I checked and cleaned every terminal, the bulb, fuses and anything else I could think of. I still believe it was the switch, and if you have ever pulled one apart you will know what I mean. The dimmer switch on a V2K is essentially an over engineered item when a simple rocker switch would have sufficed. When assembled it relies wholly on a plastic pin pressing against the body of the switch to maintain the electrical contact. Oh and do not ever lose the tiny ball bearing as nothing will work without it. So in the end it all worked out and I once again have my knees in the breeze.

Cheers and Beers.

Bob
Popeye is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlight problem - any ideas? RogerE Vulcan 1700 7 11-21-2013 06:42 PM
trade my aftermarket headlight for stock 900 custom headlight doughrek Bikes For Sale 2 07-17-2011 12:02 AM
Headlight electrical problem happyrox2 General Vulcan Talk 2 12-31-2010 06:57 PM
Vulcan 800 Headlight Problem jukeboxhero Vulcan 800 0 07-16-2009 09:47 PM
WTT cyclopse / wave headlight & mount for stock vulcan 900 headlight & mount doughrek Wanted to buy or trade Items 0 06-09-2009 12:20 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome