larry wisconsin - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-20-2009, 09:36 PM Thread Starter
Junior Member
 
Join Date: Jul 2009
Posts: 1
larry wisconsin

ignition fuse on 2004 1500 vulcan nomad keeps blowing any idea what to look for so I can get back out on road
lhouk is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-21-2009, 06:49 AM
Senior Member
 
DubsVulcan's Avatar
 
Join Date: Oct 2008
Location: Knoxville, TN
Posts: 181
I'm sure others will chime in but more than likely you have a wire shorting out. Check the wiring closely to see if any have be rubbed thru. The switch could be shorting internally but I would bet a wire is shorting somewhere in your ignition system. Hope you find it!
Bernie

PGR Member
MSF Instructor
Vietnam Veteran
2004 Vulcan 1500 Classic
1983 Gold Wing
DubsVulcan is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Larry lar519 New Member Introductions 1 10-10-2017 08:37 AM
Hello, I'm Larry lwmullis New Member Introductions 1 07-16-2015 08:56 AM
Hello from Larry in Madison Ohio lardog63 New Member Introductions 17 04-20-2014 04:49 PM
Larry P larryjprince New Member Introductions 0 06-15-2012 04:19 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome