riser install problem - Kawasaki Vulcan Forum : Vulcan Forums
» Insurance
» Sponsors
Go Back   Kawasaki Vulcan Forum : Vulcan Forums > Motorcycle Models > Vulcan 1600

Reply
 
Thread Tools Display Modes
Old 11-02-2012, 07:33 PM   #1
pittdave
Senior Member
 
pittdave's Avatar
 
Join Date: Sep 2012
Posts: 139
Default riser install problem

I installed some 2" risers today and now my throttle decel is very slow and sticky. accel seems to be ok but i cant seem to adjust it to where it is smooth


what i am doing wrong

thanks,
PD
pittdave is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-03-2012, 04:31 AM   #2
Bear2123
Top Contributor
 
Bear2123's Avatar
 
Join Date: Oct 2011
Location: SW Chicago suburbs
Posts: 4,359
Default

Either re-route the cables, or replace them with longer ones.
Bear2123 is offline   Reply With Quote
Old 11-03-2012, 05:24 AM   #3
photographe83
Junior Member
 
Join Date: Oct 2012
Posts: 5
Default riser install problem

hi, with 2 '' risers it's not normal you have a problem with your clutch cable, i have the same on mine with no problem, have you adjust your clutch cable at the handlebars and the cable adjuster in the midle of the cable ? excuse me for my english !!!!!!!!!
photographe83 is offline   Reply With Quote
Old 11-03-2012, 07:30 AM   #4
puckoach
Senior Member
 
puckoach's Avatar
 
Join Date: Jan 2010
Location: Boston burbs
Posts: 454
Default

I have an 06 Nomad.

I don't know what model the OP has.

On a Nomad, the clutch is by fluid, not cable.

That said, his problem is throttle. On my Nomad, when I installed 4 inch up, 2 inch back risers, only the hoses were stretched out to limit. The throttle cables still had plenty of "play". So, I did not try and pull "slack" from any side, of any guides.

So, what model do you have, and did you pull slack, and if so, from where.

Where are your cables now, in front of, or behind the risers ? Are the nuts tight coming out of the hand grip housing ?

The more detail you provide, the better answers the forum members can provide.
__________________
06 Kawi Vulcan Nomad - Cobra Lite Bar, Phat II Risers, Vista Cruise, Krusier Kady, Kuryakyn Longhorn Dually Pegs, Mustang w/ Backrest, Vance & Hines Dual Baggers, PC III, Cobra Luggage Rack, Electrical Connection LED R,B, T Conversion, Jay Stephens LED Tail Light, Classic Chaps, Avon Cobra's.
puckoach is offline   Reply With Quote
Old 11-03-2012, 10:33 AM   #5
pittdave
Senior Member
 
pittdave's Avatar
 
Join Date: Sep 2012
Posts: 139
Default

a-ha.. cruise control was locking too hard and restricting movement
pittdave is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:24 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum