Kawasaki Vulcan Forum : Vulcan Forums - View Profile: sfair
Go Back   Kawasaki Vulcan Forum : Vulcan Forums

sfair sfair is offline

Top Contributor

Visitor Messages

Showing Visitor Messages 1 to 10 of 63
  1. Hells Keeper
    07-19-2014 01:56 PM
    Hells Keeper
    Good Afternoon sfair!
    I thought I would directly to you with my problem because I have little over a week to make Sturgis. My problem is I stalled on the way to town. I thought I was out of gas though the gauge showed I had gas. I added a gallon of gas to no luck. I trailer-ed the bike to get back home. I have a 2004 Vulcan 1600a classic with cobra pipes and K&N air filter. I recently installed the Cobra Fuel controller. I can get the bike started but it stalls. It will back fire through the throttle body and at times through the exhaust. I have removed the controller and reset the ECM by disconnecting the battery. Problem still there. I have checked, cleaned every sensor and flushed the injectors. Everything seems fine. I have used Gadgets site for a lot of references. I have gone through the forums for similar problem but to no avail. Tonight I am going to do a fuel pressure check but it seems fine from what I have seen so far. Even cleaned the fuel screen out.
    Any thoughts?
  2. greyhairhoon
    07-14-2014 05:15 PM
    greyhairhoon
    Hello Sfair, Can you do me a favour and have a look at the thread "Rectifier connector source found" I have bought a VN2000 and it has the corroded reg plug and pins etc. I have been asking some questions on there and have ordered some parts etc. I have been hoping you would chime in there, so I am giving you a nudge. You opinion would be much appreciated.
    Thanks.
  3. tcgaboy
    07-08-2014 09:39 AM
    tcgaboy
    Hello Sir I am having an issue with my 1998 1500 Classic not starting. It has 52k miles and I bought it new. This is the first time I've had any issue with it not starting. It began doing this on the last time I rode it a week ago. Then it was slow to start but did start and ran well until I shut it off and again very slow to start. I installed new plugs since and air filter. I am using 100% gas in it and have for some time. Any help with this will be greatly appreciated. TC
  4. aeroden
    07-04-2014 03:13 AM
    aeroden
    Hi Sfair,
    Happy Independence day!
    I wish you open roads and nice tailwind
    Thank you again for so much help you provide us here.
  5. blackriot
    06-10-2014 02:17 PM
    blackriot
    sweet thx kind sir
  6. blackriot
    06-10-2014 03:15 AM
    blackriot
    Hey Sfair had a question for you. I have the opportunity to purchase a Brand new 2012 vulcan 900 from a dealership that has been sitting in thier showroom for about a year. What are the concerns or question that i should ask about the bike? Does oil and other lubricates that have been sitting that long affect the bike or do dealerships for the most part keep up to date on liquid age and what not? thanks in advance.
  7. Krich1979
    04-26-2014 06:42 PM
    Krich1979
    Hi Sfair,

    I have a 1988 Vulcan 1500 SE that I got in pieces and now that everything is together, the bike turns over but has no spark to the cylinders. I followed a thread between Martync and you from Dec. 2013 and everything mentioned there has been checked but still no firing on the engine.

    Any ideas?

    Keegan
  8. Aleco
    01-09-2014 01:17 PM
    Aleco
    Hello Sfair, sorry to bother you.
    I need to ask if this fuel pump will fit my vn900 2009 custom

    http://www.ebay.com/itm/281038401261...S:1123&vxp=mtr

    The seller said if my actual pump is UC-T30 it will work, but mine is UC-T35.
    The bike models they mention use same pump as mine, this is according to kawasaki site, they all use same part number, dont know what to do. I'm still testing fuses and relays, after that pump is coming out to see in what condition it is, I suspect is dirty.

    Your help will be much appreciated.
  9. WildMan
    12-29-2013 07:45 PM
    WildMan
    the videohttp://www.vulcanforums.com/forums/s...t=97602&page=8 has been posted on page 8 at the bottom.
  10. kevindtimm
    11-20-2013 08:04 AM
    kevindtimm
    Thanks, will do.

About Me

  • About sfair
    Disable Sidebar in Forum view
    Enable

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 07-21-2014 10:45 PM
  • Join Date: 04-29-2009
  • Referrals: 0

Feedback Score

iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View Complete Feedbacks for sfair
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0

All times are GMT -5. The time now is 07:59 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum