New Voyager 1700 - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-24-2012, 03:31 AM Thread Starter
Junior Member
 
Join Date: Apr 2012
Posts: 14
New Voyager 1700

We picked up my new VV-ABS a week ago today and it's time for the 600 mile service. Obviously - we really like the bike. Besides an the obvious oil change, any other suggestions?
Shock is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-24-2012, 09:43 AM
Top Contributor
 
rick's Avatar
 
Join Date: Mar 2008
Location: Chatsworth, Ga.
Posts: 3,223
Garage
Check the torque on all your bolts, motor mounts, and axles would be on the top of my list. Should check your fluid level at this time also, brake fluids and anti freeze. Believe its belt drive, maybe check the tension on this as well.
rick is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan Forum : Vulcan Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome