Pocatello Idaho - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-12-2012, 07:20 PM Thread Starter
Junior Member
 
Join Date: Sep 2012
Location: Pocatello, Id
Posts: 6
Pocatello Idaho

Just bought my Vulcan the end of September and have since put almost 1500 miles on it, cobra swept exhaust, led turn signals, clear tail light, and that's about it until next summer, looking forward to big air and a fuel tuner
Fletch is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-13-2012, 08:07 AM
Top Contributor
 
Bear2123's Avatar
 
Join Date: Oct 2011
Location: SW Chicago suburbs
Posts: 4,477
Great! Hello & Welcome! Enjoy the scoot...
Bear2123 is offline  
post #3 of 3 (permalink) Old 11-13-2012, 09:09 AM
Administrator
 
MN-Rider's Avatar
 
Join Date: Apr 2008
Location: Twin Cities, MN
Posts: 6,592
Garage
MN-Rider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan Forum : Vulcan Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome