Coolant shows low- - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-04-2012, 03:18 PM Thread Starter
Member
 
Join Date: May 2012
Location: Lynchburg, Va.
Posts: 49
Coolant shows low-

But when I removed the cap to add , the radiator was full up to the top of the pipe- What goes ? Suspect not circulating , not getting hot but not riding that much, 22 year old tires waiting new rubber. Any thoughts?
Thanks,OS
old sinner is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-04-2012, 04:23 PM
Top Contributor
 
Blaine's Avatar
 
Join Date: Mar 2011
Location: Prince Edward Island Canada
Posts: 1,025
Quote:
Originally Posted by old sinner View Post
But when I removed the cap to add , the radiator was full up to the top of the pipe- What goes ? Suspect not circulating , not getting hot but not riding that much, 22 year old tires waiting new rubber. Any thoughts?
Thanks,OS
The rad should be full.You should only need to add coolant to the over flo bottle.

If at first you do succeed,try not to look surprised!
Blaine is offline  
post #3 of 3 (permalink) Old 12-04-2012, 06:41 PM
Top Contributor
 
Join Date: Sep 2012
Location: Louisville, KY
Posts: 607
Garage
I'd be afraid to ride to the corner on 22 year old tires. Six years is about the max they recommend before replacing.

2006 Vulcan 500 LTD
2013 Suzuki V-Strom 650 ABS Adventure
Gary W. is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan Forum : Vulcan Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome