Need Help Please-issue with turn signals - Page 2 - Kawasaki Vulcan Forum : Vulcan Forums
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 14 (permalink) Old 11-09-2012, 03:16 PM Thread Starter
Junior Member
 
wildirishman64's Avatar
 
Join Date: Jul 2009
Location: Berea, KY
Posts: 28
They are bulbs. (Halogen), I know they blink when I first put them on. I did notice that they are a single filament. In the front I've read that they should be two? Also, I took one of the wires from the new light off and the rear now works crazy?

2008 Vulcan 900 LT From the Bluegrass State
USAF 85-89
Patriot Guard
Rolling Thunder 2011



Be Irish or Go HOME
wildirishman64 is offline  
Sponsored Links
Advertisement
 
post #12 of 14 (permalink) Old 11-09-2012, 05:14 PM
Top Contributor
 
Join Date: Apr 2009
Posts: 8,491
Post back with make and model number of signals that you are trying to install.
A link would be nice, too.

Post back.
sfair is offline  
post #13 of 14 (permalink) Old 11-10-2012, 06:43 AM
Senior Member
 
Vulcar's Avatar
 
Join Date: Sep 2012
Posts: 125
Yep, since the front are used as turn signals and running lights, they will have two filiments. The rear are just flashers and will have only one filiment. Normaly due to bulb type, one will not install in the other because the pins are spaced different on the bulbs.
Like Sfair mentioned give us some numbers and pics if available.


2007 VN900 Classic LT (Dragon Theme)
Cobra- Pipes, FI2000, Passenger Floor boards, Engine guard and luggage rack.
Memphis Shade with 9" windshield.
Mustang seat
Chrome covers for neck, radiator, Rear brake Master Cylinder, and regulator.
Kuryakan Grips
RC Components Nitro Chrome wheels w/ Night Dragon Tires.
Çobra Power Flo breather
Vulcar is offline  
post #14 of 14 (permalink) Old 11-10-2012, 06:57 AM
Member
 
Collinba's Avatar
 
Join Date: Jan 2012
Location: Toronto
Posts: 69
Garage
Sounds as though you don't have a ground. If you replaced the turn signal with an automotive one you likely need to ground it. When I replaced mine with the Single Minder relay to automatically turn the flash off after 20 seconds they provided a sparate ground wire that I had to install as the OEM relay does not require a ground wire. There is a good ground point on the right side under the battery cover they have already installed a couple of ground wires.

2010 Classic LT
Collinba is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan Forum : Vulcan Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome