installed parts. keeps dying - Kawasaki Vulcan Forum : Vulcan Forums
 9Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 27 (permalink) Old 04-29-2017, 06:15 PM Thread Starter
pah
Member
 
Join Date: Feb 2017
Location: Joliet, IL
Year/Make/Model: 09 Vulcan 900 Custom
Color: Burnt Orange
Gender: Male
Posts: 50
Garage
Angry installed parts. keeps dying

im soo dang frustrated.

I installed the freedom performance sharp curve on my vn900.

started it up and it was perfect.

added the fuel controller Fi2000 PowrPro Black
as well the PowrFlo Air Intake System

now the bike doesnt seem to start up smooth. The idle is very low and if i try to give it some gas it will die.
unless i barely accelerate it will them work.

Any ideas what is going on ?
personally im thinking its the fuel controller but im just pissed after doing this install slow so i dont jack it up ..

Thanks
darkkon likes this.
pah is offline  
Sponsored Links
Advertisement
 
post #2 of 27 (permalink) Old 04-29-2017, 06:32 PM
Top Contributor
 
revrider's Avatar
 
Join Date: Dec 2014
Location: syracuse ny
Year/Make/Model: 2010 NOMAD
Displacement/CC's: 1700
Color: Black/titanium
Posts: 1,290
Garage
Quote:
Originally Posted by pah View Post
im soo dang frustrated.

I installed the freedom performance sharp curve on my vn900.

started it up and it was perfect.

added the fuel controller Fi2000 PowrPro Black
as well the PowrFlo Air Intake System

now the bike doesnt seem to start up smooth. The idle is very low and if i try to give it some gas it will die.
unless i barely accelerate it will them work.

Any ideas what is going on ?
personally im thinking its the fuel controller but im just pissed after doing this install slow so i dont jack it up ..

Thanks
Tis why I leave my toys stock,
revrider is offline  
post #3 of 27 (permalink) Old 04-29-2017, 08:38 PM
Senior Member
 
Join Date: May 2013
Posts: 161
Quote:
Originally Posted by pah View Post
im soo dang frustrated.

I installed the freedom performance sharp curve on my vn900.

started it up and it was perfect.

added the fuel controller Fi2000 PowrPro Black
as well the PowrFlo Air Intake System

now the bike doesnt seem to start up smooth. The idle is very low and if i try to give it some gas it will die.
unless i barely accelerate it will them work.

Any ideas what is going on ?
personally im thinking its the fuel controller but im just pissed after doing this install slow so i dont jack it up ..

Thanks
Probably not the power curve or the air intake system. Take off the fuel controller and see where your at.
Or the power curve and fuel controller are not playing nice with each other. If it runs good with just the curve and air intake, then try it with the fuel controller and no power curve, if it runs good then you have a conflict. (If you can do all those things, I don't know.) These are just total guesses though.
pah likes this.

2016 Vulcan 900 LT
Qwntm is offline  
 
post #4 of 27 (permalink) Old 04-29-2017, 08:41 PM Thread Starter
pah
Member
 
Join Date: Feb 2017
Location: Joliet, IL
Year/Make/Model: 09 Vulcan 900 Custom
Color: Burnt Orange
Gender: Male
Posts: 50
Garage
Quote:
Originally Posted by Qwntm View Post
Probably not the power curve or the air intake system. Take off the fuel controller and see where your at.
Or the power curve and fuel controller are not playing nice with each other. If it runs good with just the curve and air intake, then try it with the fuel controller and no power curve, if it runs good then you have a conflict. (If you can do all those things, I don't know.) These are just total guesses though.
Thanks, going to remove the fuel controller tomorrow. Don't I need one? If it isn't playing nice should I have it exchanged?

Sent from my SM-N920T using Tapatalk
pah is offline  
post #5 of 27 (permalink) Old 04-29-2017, 09:24 PM
Top Contributor
 
crazyriderguy's Avatar
 
Join Date: May 2014
Location: Wichita, KS Area
Year/Make/Model: 2012 VN900LT
Displacement/CC's: 903
Color: Black/Silver
Gender: Male
Posts: 802
Garage
Quote:
Originally Posted by pah View Post
Quote:
Originally Posted by Qwntm View Post
Probably not the power curve or the air intake system. Take off the fuel controller and see where your at.
Or the power curve and fuel controller are not playing nice with each other. If it runs good with just the curve and air intake, then try it with the fuel controller and no power curve, if it runs good then you have a conflict. (If you can do all those things, I don't know.) These are just total guesses though.
Thanks, going to remove the fuel controller tomorrow. Don't I need one? If it isn't playing nice should I have it exchanged?

Sent from my SM-N920T using Tapatalk
Yeah, you will want that FC on there. Bike will run too lean otherwise. If the bike is idling too low, try turning up the idle speed. The adjustment is around the air box area.
crazyriderguy is online now  
post #6 of 27 (permalink) Old 04-29-2017, 09:26 PM
Top Contributor
 
crazyriderguy's Avatar
 
Join Date: May 2014
Location: Wichita, KS Area
Year/Make/Model: 2012 VN900LT
Displacement/CC's: 903
Color: Black/Silver
Gender: Male
Posts: 802
Garage
Quote:
Originally Posted by Qwntm View Post
Quote:
Originally Posted by pah View Post
im soo dang frustrated.

I installed the freedom performance sharp curve on my vn900.

started it up and it was perfect.

added the fuel controller Fi2000 PowrPro Black
as well the PowrFlo Air Intake System

now the bike doesnt seem to start up smooth. The idle is very low and if i try to give it some gas it will die.
unless i barely accelerate it will them work.

Any ideas what is going on ?
personally im thinking its the fuel controller but im just pissed after doing this install slow so i dont jack it up ..

Thanks
Probably not the power curve or the air intake system. Take off the fuel controller and see where your at.
Or the power curve and fuel controller are not playing nice with each other. If it runs good with just the curve and air intake, then try it with the fuel controller and no power curve, if it runs good then you have a conflict. (If you can do all those things, I don't know.) These are just total guesses though.
OP has has the big 3 installed. Not sure where you got the got the idea they have more than one FC onboard.
crazyriderguy is online now  
post #7 of 27 (permalink) Old 04-30-2017, 05:18 AM Thread Starter
pah
Member
 
Join Date: Feb 2017
Location: Joliet, IL
Year/Make/Model: 09 Vulcan 900 Custom
Color: Burnt Orange
Gender: Male
Posts: 50
Garage
So while sleeping I just remembered something. When looking at the inside box there is this piece or the right side.

Is that like an idle adjustment? Also I don't think I put it back in its bracket so it's just hanging.



Sent from my SM-N920T using Tapatalk
pah is offline  
post #8 of 27 (permalink) Old 04-30-2017, 06:20 AM
Top Contributor
 
Bandit's Avatar
 
Join Date: Apr 2014
Location: Rochester, New York
Year/Make/Model: 2016 VN 900 Custom
Displacement/CC's: 900
Color: Pearl Crystal White/Metallic Carbon Gray
Gender: Male
Posts: 629
Quote:
Originally Posted by pah View Post
So while sleeping I just remembered something. When looking at the inside box there is this piece or the right side.

Is that like an idle adjustment? Also I don't think I put it back in its bracket so it's just hanging.



Sent from my SM-N920T using Tapatalk
Yes,that is the idle speed adjustment knob.
pah likes this.

2016 VN900 Custom
Cobra FI2000R Fuel Controller
Kuryakyn Voltmeter
Kawasaki Mini Tachometer
K&N Air Filter
Kuryakyn ISO Grips With Dual Throttle Bosses
Cobra Standard Backrest/Rack With Saddlemen Roll Bag
Cobra Freeway Bars
DesertDawg Freeway Bar Chaps
Mustang Wide Vintage Touring Seat With Drivers Backrest
Memphis Shades Batwing Fairing With Lowers
Genmar X12 2" Risers
Bandit is offline  
post #9 of 27 (permalink) Old 04-30-2017, 06:32 AM Thread Starter
pah
Member
 
Join Date: Feb 2017
Location: Joliet, IL
Year/Make/Model: 09 Vulcan 900 Custom
Color: Burnt Orange
Gender: Male
Posts: 50
Garage
Quote:
Originally Posted by Bandit View Post
Yes,that is the idle speed adjustment knob.
Well I bet that will do it lol. Thanks

Sent from my SM-N920T using Tapatalk
pah is offline  
post #10 of 27 (permalink) Old 04-30-2017, 09:09 AM Thread Starter
pah
Member
 
Join Date: Feb 2017
Location: Joliet, IL
Year/Make/Model: 09 Vulcan 900 Custom
Color: Burnt Orange
Gender: Male
Posts: 50
Garage
I checked and what's nice is the fuel manager is Bluetooth. I was running about 650ish on idle LOL no wonder it was dying.. Set it to about 1k and when this effing weather is nice I can test it.


Sent from my SM-N920T using Tapatalk
pah is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan Forum : Vulcan Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome