Kawasaki Vulcan Forum : Vulcan Forums - View Single Post - Who has or has not had problems with their 900?
View Single Post
post #1 of (permalink) Old 07-28-2016, 05:37 PM Thread Starter
Bandit
Top Contributor
 
Bandit's Avatar
 
Join Date: Apr 2014
Location: Rochester, New York
Year/Make/Model: 2016 VN 900 Custom
Displacement/CC's: 900
Color: Pearl Crystal White/Metallic Carbon Gray
Gender: Male
Posts: 606
Who has or has not had problems with their 900?

I have owned four of these bikes now and was wondering what other owners who have actually accumulated some miles have or have not seen for problems with these bikes.I have a tendency to switch bikes often so have never really put a lot of miles on any of the four.I did have a 2009 that dripped some coolant at about 3000 miles which I resolved by tightening some hose clamps under the gas tank.Also had small amounts of oil form (same bike) on the wiring harness that runs to the regulator.Never did resolve that problem.I never had any of the frequently talked of belt noise and never experienced stator failure but I never put more than 4500 miles on any of the four bikes.Please state year,mileage,and whether modifications may have caused the problem when responding.

2016 VN900 Custom
Cobra FI2000R Fuel Controller
Kuryakyn Voltmeter
Kawasaki Mini Tachometer
K&N Air Filter
Kuryakyn ISO Grips With Dual Throttle Bosses
Saddlebags Installed Using Easybrackets
Cobra Freeway Bars
DesertDawg Freeway Bar Chaps
Mustang Wide Vintage Touring Seat With Drivers Backrest
Memphis Shades Batwing Fairing With Lowers
Genmar X12 2" Risers
Bandit is offline  
 
 
For the best viewing experience please update your browser to Google Chrome