Front disc on 07 500 are pretty squeaky - Kawasaki Vulcan Forum : Vulcan Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-12-2012, 01:21 AM Thread Starter
Member
 
Join Date: Sep 2012
Location: Chicago, IL
Posts: 67
Front disc on 07 500 are pretty squeaky

I bought the bike in September, it had 4k miles on it and since I purchased the bike the front discs have been pretty squeaky. It is when I bring in the brake lever. I had thought it was just breaking in the break pads if the bike had been sitting a short amount of time but I don't think that is it.

I have noticed when I pull the brake lever rather quickly it won't squeak. I have a feeling it might be glazing over.

Last edited by blackbird68; 11-12-2012 at 01:25 AM.
blackbird68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan Forum : Vulcan Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome